helpf.pro
Регистрация
 0 
Распечатать

Добавление дополнительных отчетов и обработок в тонком клиенте БП 3.0, ЗУП 3.0, УТ 11

Любой отчет и обработку можно подключить пользователям как дополнительные отчеты или обработки, вот например пункт в БП - Банк:

Добавление происходит через

 

далее Дополнительные отчеты и обработки, в списке нажмите Создать и Выберите Файл отчета/обработки:


Перед добавлением файл нужно подготовить, дописать в модуль объекта код подключения:

Для обработок код:

Код 1C v 8.3
 Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = Новый Структура;

//Вид
//Строка, вид обработки, один из возможных: 
//"ДополнительнаяОбработка", "ДополнительныйОтчет", "ЗаполнениеОбъекта", "Отчет", "ПечатнаяФорма", "СозданиеСвязанныхОбъектов" 
ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");

//Массив строк имен объектов метаданных в формате: 
//<ИмяКлассаОбъектаМетаданного>.[ * | <ИмяОбъектаМетаданных>]. 
//Например, "Документ.СчетЗаказ" или "Справочник.*". 
//Прим. параметр имеет смысл только для назначаемых обработок, для глобальных может не задаваться. 
ПараметрыРегистрации.Вставить("Назначение", Новый СписокЗначений);

//Наименование обработки, которым будет заполнено наименование элемента справочника по умолчанию - краткая строка для идентификации обработки администратором 
ПараметрыРегистрации.Вставить("Наименование", "Сравнение документов БУХ и УТ");

//Версия обработки в формате “<старший номер>.<младший номер>” используется при загрузке обработок в информационную базу. Например “. 
ПараметрыРегистрации.Вставить("Версия", "1.0");

//Принимает значение Истина или Ложь, в зависимости от того, требуется ли устанавливать или отключать безопасный режим исполнения обработок. Если истина, обработка будет запущена в безопасном режиме. Более подбробно о безопасном режиме в справке к платформе 1С:Предприятие. 
ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);

//Краткая информация по обработке, описание обработки. 
ПараметрыРегистрации.Вставить("Информация", "");

//Команды, поставляемые обработкой. Таблица значений с колонками: 
ПараметрыРегистрации.Вставить("Команды", Новый СписокЗначений);

ТаблицаКоманд = ПолучитьТаблицу_Команд();


  ДобавитьКоманду(ТаблицаКоманд,
          "Сравнение документов БУХ и УТ", //Представление
          "Сравнение документов БУХ и УТ", //Идентификатор
          "ОткрытиеФормы", //Использование
          Ложь, //ПоказыватьОповещение
          ""); //Модификатор


  ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;

КонецФункции


Функция ПолучитьТаблицу_Команд()


  Команды = Новый ТаблицаЗначений;
  
  //Представление – представление команды в пользовательском интерфейсе;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  
  //Идентификатор – идентификатор команды; 
  //любая строка, уникальная в пределах данной обработки (отчета). 
  //В случае с обработками печатных форм на основе макета табличного документа передается список макетов, 
  //на основе которых нужно получить печатную форму 
  //(см. описание параметра ИменаМакетов процедуры УправлениеПечатьюКлиент.ВыполнитьКомандуПечати в разделе Печать). 
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  
  //"ОткрытиеФормы" – открыть форму обработки; 
  //"ВызовКлиентскогоМетода" – вызвать клиентскую экспортную процедуру из модуля формы обработки; 
  //"ВызовСерверногоМетода" – вызвать серверную экспортную процедуру из модуля объекта обработки.
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
 
  //ПоказыватьОповещение – если Истина, требуется показать оповещение при начале и при завершении работы обработки. 
  //Имеет смысл только при запуске обработки без открытия формы. 
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  
  //Модификатор – дополнительный модификатор команды. 
  //Используется для дополнительных обработок печатных форм на основе табличных макетов, 
  //для таких команд должен содержать строку ПечатьMXL (см. пример в демонстрационной конфигурации).
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  
  Возврат Команды;
           
КонецФункции


Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")


  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры

Для отчетов и печатных форм меняйте параметр Вид:

Код 1C v 8.3
 //"ДополнительнаяОбработка", "ДополнительныйОтчет", "ЗаполнениеОбъекта", "Отчет", "ПечатнаяФорма", "СозданиеСвязанныхОбъектов" 
ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");

Возможные значения этого поля приведу в виде таблицы

Значение поля "Вид" Расположение команды

Расширение

файла

ПечатнаяФорма В меню "Печать" на форме объекта или списка epf
ЗаполнениеОбъекта В меню "Заполнить" на форме объекта или списка epf
СозданиеСвязанныхОбъектов В меню "Создать на основании" - "Создание связанных объектов.." на форме объекта или списка epf
Отчет В меню "Отчеты" на форме объекта или списка erf
ДополнительнаяОбработка В списке соответствующих подсистем в меню "Сервис" - "Дополнительные обработки" epf
ДополнительныйОтчет В списке соответствующих подсистем в меню "Сервис" - "Дополнительные отчеты" erf

Это поле может принимать одно из значений, возвращаемых функциями в типовых конфигурациях:

 ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработки<Вид>(). Например, для вида "ПечатнаяФорма" есть функция ВидОбработкиПечатнаяФорма(). 

Разместил:   Версии: |  Дата:   Прочитано: 677
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 38
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 8
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Excel файл как Внешний источник данных 5
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.