helpf.pro
Регистрация
 -1 
Распечатать

Сравнение двух структур

Код 1C v 8.х
 // Сравнение 2-х стурктур
// Возвращает структуру с полями которые отличаются и значением из сравниваемой
// Если в стСравнимое нет нужного поля,то в результат добавляется поля = Неопределенно
// стОсновная, стСравнимое - сравниваемые структуры
// ДоПервойРазницы - ищет только одно отличие
Функция СравнитьСтруктуры(стОсновная, стСравнимое,ДоПервойРазницы = Ложь) Экспорт
Результат = Новый Структура;

Для каждого текПоле из стОсновная цикл
ЗначениеСравнение = ?(стСравнимое.Свойство(текПоле.Ключ), стСравнимое[текПоле.Ключ], Неопределено);
Если текПоле.Значение ЗначениеСравнение тогда
Результат .Вставить(текПоле.Ключ,ЗначениеСравнение);
Если ДоПервойРазницы тогда
Прервать;
КонецЕсли;
КонецЕсли;
КонецЦикла;

Возврат Результат;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6420
 -1 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.