helpf.pro
Регистрация
 -3 
Распечатать

Сравнение двух структур

Код 1C v 8.х
 // Сравнение 2-х стурктур
// Возвращает структуру с полями которые отличаются и значением из сравниваемой
// Если в стСравнимое нет нужного поля,то в результат добавляется поля = Неопределенно
// стОсновная, стСравнимое - сравниваемые структуры
// ДоПервойРазницы - ищет только одно отличие
Функция СравнитьСтруктуры(стОсновная, стСравнимое,ДоПервойРазницы = Ложь) Экспорт
Результат = Новый Структура;

Для каждого текПоле из стОсновная цикл
ЗначениеСравнение = ?(стСравнимое.Свойство(текПоле.Ключ), стСравнимое[текПоле.Ключ], Неопределено);
Если текПоле.Значение ЗначениеСравнение тогда
Результат .Вставить(текПоле.Ключ,ЗначениеСравнение);
Если ДоПервойРазницы тогда
Прервать;
КонецЕсли;
КонецЕсли;
КонецЦикла;

Возврат Результат;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 15971
 -3 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 11
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который выпускает компания 1С . Что такое
Google maps : вывод точек на карту и режим панорамы 5
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С возможностью просмотра панора
QR код в 1С 20
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После тог
Алгоритм шифрования RC4 1
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации алгоритма шифрования RC4 на встроенном яз
Библиотека кода: Сравнить две таблицы значений 0
//Сравнивает две таблицы значений // Функция ТаблицыЗначенийРавны(ТаблицаЗначений1, ТаблицаЗначений2) Экспорт Если ТипЗнч(ТаблицаЗначений1) Тип("ТаблицаЗначений") ИЛИ ТипЗнч(ТаблицаЗначений2) Тип("ТаблицаЗначений") Тогда Возв
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.