helpf.pro
Регистрация
 0 
Распечатать

Массив ~ Как удалить повторяющиеся элементы массива?

Код 1C v 8.х
 Функция УдалитьПовторяющиесяЭлементыМассива(Массив) Экспорт 
ТекущийИндекс = 0;
ВсегоЭлементов = Массив.Количество();
Пока ТекущийИндекс < ВсегоЭлементов Цикл
Индекс2 = ТекущийИндекс + 1;
Пока Индекс2 < ВсегоЭлементов Цикл
Если Массив[Индекс2] = Массив[ТекущийИндекс] Тогда
Массив.Удалить(Индекс2);
ВсегоЭлементов = ВсегоЭлементов - 1;
Иначе
Индекс2 = Индекс2 + 1;
КонецЕсли;
КонецЦикла;
ТекущийИндекс = ТекущийИндекс + 1;
КонецЦикла;
Возврат Массив;
КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 15556
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Посмотреть все результаты поиска похожих
Комментарии
all4cf
27.07.2016 01:14Комментарий: 2
all4cf

как Удалить дубли из массива

Код 1C v 8.х
 // Заполняет массив-приемник уникальными значениями из массива-источника.
 // Если элемент в массиве-приемнике уже существует, то добавления нового элемента не происходит.
 //
 // Параметры:
 //  МассивПриемник – Массив – массив, который заполняется уникальными значениями
 //  МассивИсточник – Массив – массив, из которого подбираются элементы в массив-приемник.
 // 
 Процедура ЗаполнитьМассивУникальнымиЗначениями(МассивПриемник, МассивИсточник) Экспорт
     Для Каждого Элемент Из МассивИсточник Цикл
        Если МассивПриемник.Найти(Элемент) = Неопределено Тогда
            МассивПриемник.Добавить(Элемент);
         КонецЕсли;
    КонецЦикла;    
КонецПроцедуры
TS_MAXIMUS
10.03.2012 13:41Комментарий: 1
TS_MAXIMUS
Ну ещё можно вот так:


Функция УдалитьПовтЭлМассива(Массив) Экспорт
индекс=0;
Пока индекс<=Массив.ВГраница() Цикл
Индекс1=Индекс + 1;
Пока Индекс1 <= Массив.ВГраница() Цикл
Если Массив[Индекс]=Массив[Индекс1] Тогда
Массив.Удалить(Индекс1);
Индекс1 = Индекс1 - 1;
КонецЕсли;
Индекс1 = индекс1 + 1;
КонецЦикла;
индекс = индекс + 1;
КонецЦикла;
Возврат Массив;

КонецФункции
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.