helpf.pro
Регистрация
 0 
Распечатать

Прогресс бар

Как подключить прогресс бар к процедурам двум, чтобы видить статус выполнения этих процедур??
есть две процедуры и треться является кнопкой, которая выполняет по очереди те две, вот как реализовать это все? чтобы при нажатии третьей процедуры/кнопки я видел в процентах состояние. Код прогресс бара есть.
Процедура КнопкаВыполнитьНажатие()
ПР=Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
Пр.ОтображатьПроцентВывода=Истина ;
Эл=Новый ЭлементРезультатаКомпоновкиДанных;

ПР.НачатьВывод();
Для А=1 По 100 Цикл
Эл.ПроцентВывода=А;
//задержка, чтобы разглядеть
Для Б=1 По 10000 Цикл КонецЦикла;
ПР.ВывестиЭлемент(Эл);
КонецЦикла;
ПР.ЗакончитьВывод();
КонецПроцедуры
я новичек, что тут куда написать нужно чтобы процесс бар выполнялся при выполнении процедур
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 4151
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Посмотреть все результаты поиска похожих
Комментарии
DJ_Serega
08.04.2013 23:05Комментарий: 1
DJ_Serega
Я так понял это вопрос по поводу 82 УП.
Есть такая тема у нас. Попробуйте так обойти данную особенность таким образом
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.