helpf.pro
Регистрация
 +3 
Распечатать

Механизм оповещений пользователя

Оповещение пользователей в 1с в управляемом приложении могут быть вызваны как самой платформой, например, при записи документа, так и разработчиком, если он применит метод глобального контекста ПоказатьОповещениеПользователя().
Код 1C v 8.2 УП
 ПоказатьОповещениеПользователя(
НСтр("ru = 'Выполнение:'"),
ПолучитьНавигационнуюСсылку(Объект.Ссылка),
Строка(Объект.Ссылка),
БиблиотекаКартинок.Информация32
);

Оповещения появляются в отдельном не модальном окне, по умолчанию привязанному к панели задач операционной системы, и затухают через несколько секунд после появления.
Если вывести несколько оповещений подряд, то пользователь сможет увидеть только последнее.
Последние несколько оповещений можно увидеть на панели истории.
title

При программном формировании оповещений важно помнить, что метод ПоказатьОповещениеПользователя() доступен только в контексте клиентской части, то есть при работе тонкого, толстого клиента или веб-клиента.
В качестве параметров метода ПоказатьОповещениеПользователя() передается строка с текстом оповещения, навигационная ссылка, текст с пояснением и картинка.
Навигационная ссылка будет представлена в области пояснения как гиперссылка, а в том случае если текст с пояснением не задан, то именно представление навигационной ссылки будет отображено в области пояснения. Получить навигационную ссылку можно для любого объекта базы с помощью глобального метода ПолучитьНавигационнуюСсылку().
Проиллюстрируем вывод оповещения при открытии документа, редактирование которого запрещено.
Код 1C v 8.2 УП
 &НаКлиенте
Процедура ПриОткрытии(Отказ)
Если ПолучитьДатуЗапретаРедактирования() >= Объект.Дата Тогда
НавигационнаяСсылка = ПолучитьНавигационнуюСсылку(Объект.Ссылка);
ПоказатьОповещениеПользователя("Только просмотр!",
НавигационнаяСсылка,
"Разрешен только просмотр документа!");
КонецЕсли;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьДатуЗапретаРедактирования()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| Константы.ДатаЗапретаРедактирования
|ИЗ
| Константы КАК Константы";
РезультатЗапроса = Запрос.Выполнить();
Возврат РезультатЗапроса.Выгрузить()[0].ДатаЗапретаРедактирования;
КонецФункции

В приведенном примере производится проверка даты запрета редактирования, установленной в константе, и в том случае если открывается документ, попадающий в период запрета, пользователю выводится оповещение. В оповещении установлена навигационная ссылка на открываемый документ, однако в окне оповещения ссылка будет установлена к тексту «Разрешен только просмотр документа».

еще пример:
Код 1C v 8.2 УП
 	#Если Клиент Тогда
Форма = Источник.ПолучитьФорму();
Если Форма.Открыта() Тогда
ПоказатьОповещениеПользователя("Документ изменен", ПолучитьНавигационнуюСсылку(Источник.Ссылка), "Изменен состав рашифровки платежей", БиблиотекаКартинок.Информация32);
КонецЕсли;
#КонецЕсли




Для Толстого клиента kojinandrej предложил следующий механизм:
1. В модуле обычного приложения в процеду ПриНачалеРаботыСистемы добавляем текст
Код 1C v 8.х
 Форма = Обработки.ОповещенияПользователя.ПолучитьФорму("Форма");
Форма.Открыть();

2. Создаем ОбщийМодуль под названием "опМодуль" в модуле вставляем текст
Код 1C v 8.х
          
Функция ВывестиОповещение(ИмяОтчета);
ИмяФайла = ПолучитьИмяВременногоФайла();
Отчет = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОтчета);
ДвоичныеДанные = Отчет.ХранилищеВнешнейОбработки.Получить();
ДвоичныеДанные.Записать(ИмяФайла);
опФорма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
опФорма.Открыть();
УдалитьФайлы(ИмяФайла);
КонецФункции

Процедура ПроверкаНовыхОповещений() Экспорт

ОтборПользователей = Новый Структура("Пользователь");
ОтборПользователей.Пользователь = ПараметрыСеанса.ТекущийПользователь;
Оповещения = РегистрыСведений.ОповещениеПользователей.Выбрать(ОтборПользователей);
КолОп = 0;
Пока Оповещения.Следующий() Цикл
Если Оповещения.Просмотрено Тогда
Продолжить;
КонецЕсли;
КолОп = КолОп + 1;
КонецЦикла;
Если (КолОп>0) Тогда
ВывестиОповещение("Оповещения пользователя");
КонецЕсли;
КонецПроцедуры

Процедура ЗадатьИнтервал(Интервал) Экспорт
ПодключитьОбработчикОжидания("ПроверкаНовыхОповещений",Интервал,5);
КонецПроцедуры

Процедура ОчиститьИнтервал() Экспорт
ОтключитьОбработчикОжидания("ПроверкаНовыхОповещений");
КонецПроцедуры

3. Создаем регистр сведений "ОповещениеПользователей". Добавляем измерения: "Пользователь" Тип:"СправочникСсылка.Пользователи", "Дата" Тип:"Дата", "Владелец" Тип:"СправочникСсылка.Пользователи", Ресурсы: "Просмотрено" Тип: "Булево", "Оповещение" Тип: "Строка"

4. Добавляем в конфигурацию необходимые Обработки и формы - пользуемся.

Принцип Работы:
При запуске 1с справой стороны в трее открыто оповещение пользователей. Открываем обработку Оповестить, пишим текст сообщения и отметив получателей отправляем сообщение.
Когда сообщение приходит получателю, то форма оповещени появляется с правой стороны. Что бы сообщение считалось прочитаным, его необходимо открыть двойным щелчком правой клавиши мыши и оно откроется в новом окне как показао на третем изображении. В дальнейшем эти сообщения можно будет просматривать во вкладке "Просмотреные"
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 18540
 +3 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Посмотреть все результаты поиска похожих
Комментарии
SVKH
19.05.2015 10:12Комментарий: 2
SVKH

E_Migachev, какие ещё обработки и формы нужно добавить, чтобы посмотреть на работу данного механизма?

asskassin
09.06.2014 14:30Комментарий: 1
asskassin

Как то все размыто... не хватает конкретики что и куда вставлять для управляемой формы

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.