helpf.pro
Регистрация
 0 
Распечатать

Формирование записей регистра расчета

Для формирования записей регистра расчета используется метод Добавить() объекта РегистрРасчетаНаборЗаписей

Код 1C v 8.2 УП
 //Формирование записей регистра расчета

// Процедура добавляет запись в регистр основных начислений.
Процедура ДобавитьСтрокуОсновныхНачислений(ДанныеСтроки, НаборЗаписей)

Движение = НаборЗаписей.Добавить();

// Предопределенные поля.
Движение.ПериодРегистрации = ПериодРегистрации;
Движение.ПериодДействияНачало = ДанныеСтроки.ДатаНачало;
Движение.ПериодДействияКонец = ДанныеСтроки.ДатаКонец;
Движение.ВидРасчета = ДанныеСтроки.ВидРасчета;
Движение.Сторно = ДанныеСтроки.Сторно;

// Измерения.
Движение.ФизЛицо = ДанныеСтроки.ФизЛицо; Движение.Организация= Организация;

// Ресурсы.
Движение.Результат = ДанныеСтроки.Результат;

// Реквизиты.
Движение.ГрафикРаботы = ДанныеСтроки.ФизЛицо.ГрафикРаботы;
Движение.Размер = ДанныеСтроки.Размер;
Движение.ВидУчетаВремени = ДанныеСтроки.ВидРасчета.ВидУчетаВремени;
Движение.Подразделение = ДанныеСтроки.Подразделение;
Движение.СтатьяЗатрат = ДанныеСтроки.ВидРасчета.СтатьяЗатрат;

КонецПроцедуры // ДобавитьСтрокуОсновныхНачислений

// Обработка проведения.
Процедура ОбработкаПроведения(Отказ)

Движения.ОсновныеНачисленияРегл.Записывать = Истина; Движения.ДополнительныеНачисленияРегл.Записывать = Истина;

// Сформировать запрос по табличной части при помощи функции общего модуля. ВыборкаОсновныеНачисления = ОбщегоНазначения.
СформироватьЗапросПоТабличнойЧасти(ЭтотОбъект, "ОсновныеНачисления").Выбрать();

// По каждой строке табличной части сформировать запись в регистр. Пока ВыборкаОсновныеНачисления.Следующий() Цикл
ДобавитьСтрокуОсновныхНачислений(ВыборкаОсновныеНачисления, Движения.ОсновныеНачисленияРегл);
настройка алгоритмов расчета

КонецЦикла;

// Запись дополнительных начислений в регистр.
ВыборкаДополнительныеНачисления = ОбщегоНазначения.
СформироватьЗапросПоТабличнойЧасти(ЭтотОбъект, "ДополнительныеНачисления").Выбрать();

Пока ВыборкаДополнительныеНачисления.Следующий() Цикл

ДобавитьСтрокуДополнительныхНачислений(ВыборкаДополнительныеНачисления, Движения.ДополнительныеНачисленияРегл);

КонецЦикла;

КонецПроцедуры // ОбработкаПроведения
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 4136
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Блокировка записей, невозможно изменить или удалить из регистра. Конфликт блокировок MS SQL + 1C 1
При попытке удалить запись из регистра сведений - получаю ошибку: она заблокирована, ошибка блокировок и т.д. Отключил всех пользователей, перезапустил сервер, пробую удалить - опять ошибка блокировки :( Путем тестов...
В ЗУП не исчисляются суммы районного коэффициента и северной надбавки? 1
В Зарплата и управление персоналом 8 почему при расчете среднего заработка для начисления очередного отпуска не исчисляются суммы районного коэффициента и северной надбавки? При исчислении среднего заработка во...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.