helpf.pro
Регистрация
 0 
Распечатать

Форма ~ Работа со стандартным периодом

Код 1C v 8.х
 Диалог = Новый ДиалогРедактированияСтандартногоПериода();
ПеременнаяТипаСтандартныйПериод = Новый СтандартныйПериод();
Диалог.Период = ПеременнаяТипаСтандартныйПериод;
Если Диалог.Редактировать() Тогда
ПеременнаяТипаСтандартныйПериод = Диалог.Период;
КонецЕсли;
Запрос.УстановитьПараметр("ДатаНачала", ПеременнаяТипаСтандартныйПериод.ДатаНачала);
Запрос.УстановитьПараметр("ДатаОкончания", ПеременнаяТипаСтандартныйПериод.ДатаОкончания);


Код 1C v 8.х
 НП = Новый НастройкаПериода	;
НП.ВариантНастройки=ВариантНастройкиПериода.Интервал;
НП.ВариантНачала=ВариантГраницыИнтервала.КонкретнаяДата;
НП.ВариантОкончания=ВариантГраницыИнтервала.КонкретнаяДата;

НП.ДатаНачала=ДатаНачала;
НП.ДатаОкончания=ДатаОкончания;
Если НП.Редактировать()Тогда
ДатаНачала=НП.ПолучитьДатуНачала();
ДатаОкончания= НП.ПолучитьДатуОкончания();
КонецЕсли;

Если ДатаОкончания=Дата('00010101') Тогда
ДатаОкончания=ТекущаяДата();
КонецЕсли;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6462
 0 
Распечатать
Возможно, вас также заинтересует
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Использование ASCII кодов в 1С 2
Хотите писать в 1С не только стандартными буквами, знаками изображенными на клавиатуре и вставлять опять же стандартные смайлики, а тем не менее существует возможность ставить дополнительные символы, так же можно...
Как выполнить перепроведение документов стандартными инструментами 1С? 1
При работе, часто бывает нужно перепровести разом документы за месяц. Удивительно, но многие не знают что есть встроенный механизм проведения: Откройте Операции - проведение документов И в открывшемся окне: 1....
Как поменять период у записей периодического независимого регистра, соответствующих ряду условий? 0
В периодическом независимом регистре сведений ОтветственныеЛицаОрганизации все записи, касающиеся организации с наименованием Групп-трейдинг, период которых меньше 01 января 2005 года, необходимо перенести на 01...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.