helpf.pro
Регистрация
 0 
Распечатать

Как сделать паузу при выполнении кода с информативным сообщением для пользователя

Реализация красивой задержки в обработках или в любом другом месте программного кода

title


Код 1C v 8.х
 
// Предваряющий код
// Место, где необходимо сделать паузу и съесть твикс )
// И, чтобы пользователь сильно не волновался вывести красивое окно с картинкой
//...
Если ФлажокИспользоватьПаузуМеждуДокументами Тогда
Форма = ПолучитьФорму("ФормаПаузы");
Форма.ПараметрФормы = ДлительностьПаузы;
Форма.ОткрытьМодально();
КонецЕсли;
//...
// Продолжить выполнение кода



Код 1C v 8.х
 
// Молуль формы "ФормаПаузы"
// В реквизитах формы создаем новый с названием ПараметрФормы к который при открытии передадим период задержки

Процедура ЗакрытиеФормыОбработки()
ЭтаФорма.Закрыть();
КонецПроцедуры

Процедура ПриОткрытии()
ПодключитьОбработчикОжидания("ЗакрытиеФормыОбработки", ПараметрФормы);
КонецПроцедуры


П.С.
При использовании в боевой базе был достигнут эффект зависания окна. Метод был использован в цикле, и после около 200 циклов окно перестало откликаться. Так что рекомендую использовать этот метод в маленьких циклах. Решил задачу через
Код 1C v 8.х
 
Предупреждение("Пауза...", ДлительностьПаузы);
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 4502
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.