helpf.pro
Регистрация
 +3 
Распечатать

Использование модальных окон в данном режиме запрещено! Модальные окна не работают, как быть?

В конфигураторе в свойства конфигурации, есть параметр «Режим использования модальности»

Режим использования модальности

Если установить Не использовать, то - принципе весь код, который после ОткрытьФормуМодально() Вопрос(), Предупреждение(), Выборов и диалогов открытия-сохранения станет работать с ошибками!


Рассмотрим пример с Использовать:

Код 1C v 8.3
 &НаКлиенте
Процедура КомандаВопрос(Команда)
Ответ = Вопрос("Ну что скажешь? ", РежимДиалогаВопрос.ДаНет);
Если Ответ = КодВозвратаДиалога.Да Тогда                                  
Сообщить("Ответили ДА!");                                              
КонецЕсли;
КонецПроцедуры

В режиме Предприятие получаем

Тест модального окна Вопрос

Если мы поставим Режим использования модальности = Не использовать то получим ошибку: Использование модальных окон в данном режиме запрещено

получим ошибку: Использование модальных окон в данном режиме запрещено

Теперь код нужно писать по новому:

Код 1C v 8.3
 &НаКлиенте
Процедура КомандаВопросПоНовому(Команда)
Оповещение = Новый ОписаниеОповещения("ОтветНаВопросЗавершение", ЭтотОбъект);
ТекстВопроса = "Ну что скажешь?";
ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
КонецПроцедуры


&НаКлиенте 
Процедура ОтветНаВопросЗавершение(Результат, ДополнительныеПараметры) Экспорт 
Если Результат = КодВозвратаДиалога.Да Тогда
Сообщить("Ответили ДА");
КонецЕсли;
КонецПроцедуры

в результате

Почему 1С решила отказаться от использования модальных окон ?

В наш век развития мобильных технологий все идет к тому - что скоро все будут работать на планшетах и телефонах. 1С сделала для этого «Web Клиент» и «Мобильное приложение».  И чтобы успешно двигаться вперед нужно решать такие проблемы как, блокировка всплывающих окон. Ведь даже обычные браузеры по умолчанию блокируют модальные (всплывающие) окна!

Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 16997
 +3 
Распечатать
Возможно, вас также заинтересует
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Автоматическая выгрузка загрузка данных используя регламентное задание 1
Для обмена данными между программами необходимо сделать следующее: 1. При помощи Конвертации Данных создать правила выгрузки данных 2. Нужно чтобы в конфигурации была обработка УниверсальныйОбменДаннымиXML ,...
Посмотреть все результаты поиска похожих
Комментарии
E_Migachev
28.07.2014 15:07Комментарий: 2
E_Migachev

ПоказатьВопрос( - это для НЕ модального режима, до он покажется и будет ждать ответа пользователя

Mokey
28.07.2014 14:30Комментарий: 1
Mokey

А ПоказатьВопрос() уже не в модальном режиме работает? И если пользователь случайно кликнул по полю за этим окном, что произойдёт? Окно с вопросом так и останется висеть неотвеченным?

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.