helpf.pro
Регистрация
 0 
Распечатать

Как сформировать диаграмму с типом График

В этом примере построим диаграмму с типом График, вида:

Вот код ее формирования:

Код 1C v 8.х
 Процедура ГрафикКолВоДоставок()

//Создаем таблицу данных
ТабД = Новый ТаблицаЗначений;
ТабД.Колонки.Добавить("ДатаК");
ТабД.Колонки.Добавить("Всего");
кп = КонПериодаЛ;           
нп = кп-(86400);
Пока кп>НачПериодаЛ Цикл 
Состояние("Кол-во Доставок на: "+ Строка(кп));
КоличествоДоставок = 0;   Тоннаж = 0;
Привилегированный.ПолучитьКоличествоДоставок(кп, КоличествоДоставок, Тоннаж);
Нстр = ТабД.Добавить();
Нстр.ДатаК=кп;
Нстр.Всего = КоличествоДоставок;
кп = нп;          
нп = кп-(86400);
КонецЦикла;
ДиаграммаВП = ЭлементыФормы.ДиаграммаКолВоДоставок;
ДиаграммаВП.КоличествоТочек=0;
ТабД.Сортировать("ДатаК Возр");
Для Каждого СтрТраб из ТабД Цикл
Точка=ДиаграммаВП.Точки.Добавить(Формат(СтрТраб.Получить(0),"ДФ=dd.MM"));
Индекс=0;
//Для Каждого Серия из ДиаграммаВП.Серии Цикл
Попытка
ДиаграммаВП.УстановитьЗначение(Точка,ДиаграммаВП.Серии[0],?(СтрТраб.Получить(1)=Неопределено,0,СтрТраб.Получить(1)));
Исключение

КонецПопытки;
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: |  Дата:   Прочитано: 1919
 0 
Распечатать
Возможно, вас также заинтересует
HTML5 Canvas в 1С 8.3 или Google нам поможет 0
Добрался я для написания маленьких тестов для 1С в плане web графики. Версии 1С 8.2.61 и 8.3.3.641. Зайдем на http://www.w3schools.com/html/html5_canvas.asp и перенесем примеры в обработку 1С. Скачать обработку: Результаты не радуют. 1С в Intern
Возможно ли поменять график работы сотрудника в ЗУП без создания документа на внутреннее перемещение 0
Вопрос: Возможно ли поменять график работы сотрудника в ЗУП без создания документа на внутреннее перемещение? Ответ: Нет, нельзя. Только через документ!
Вывод Диаграммы График Валют, Сохранение диаграммы, графиков и гистограмм в виде Картинки 0
Алгоритм обработки выполняет запрос к регистру сведений " курсы валют" за определенный пользователем период. Полученные данные выборки в цикле выводятся в элемент экранной формы " диаграмма" в режиме построения...
Вывод результата запроса в сводную диаграмму 0
Запрос = Новый Запрос( " ВЫБРАТЬ | ТоварыНаСкладахОстаткиИОбороты.Склад КАК Склад, | ТоварыНаСкладахОстаткиИОбороты.Склад.Представление, | ТоварыНаСкладахОстаткиИОбороты.Номенклатура КАК Номенклатура, ...
Где в ЗУП быстро посмотреть, по какому графику работы трудится сотрудник на данный момент? 0
В справочнике Сотрудники откройте вашего сотрудника и загляните на вкладку Кадровые данные. В таблице Место работы отображаются его данные, в том числе и график.
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.