helpf.pro
Регистрация
 +2 
Распечатать

Как установить цену из РегистраСведений на дату создания документа

Код 1C v 8.3
 

&НаКлиенте
Процедура ТоварНоменклатураПриИзменении(Элемент)
СтрокаТабличнойЧасти = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные;
Номенклатура = СтрокаТабличнойЧасти.Номенклатура;
ТипЦен = ЭтаФорма.ТипЦен;
ТекДата = Объект.Дата;
СтрокаТабличнойЧасти.Цена = ПолучитьЦену(Номенклатура, ТипЦен, ТекДата);
КонецПроцедуры


&НаСервере
Функция ПолучитьЦену(Номенклатура, ТипЦен, ТекДата) Экспорт
Отбор = Новый Структура;
Отбор.Вставить("Номенклатура",Номенклатура);
Отбор.Вставить("ТипЦены",ТипЦен);
ЦенаТовара = РегистрыСведений.ЦеныНоменклатуры.ПолучитьПоследнее(ТекДата,Отбор);
Возврат ЦенаТовара.Цена;
КонецФункции


Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 5217
 +2 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 3
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 15
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 13
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 44
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С 8.x : Как убрать лидирующие нули в номере Документа (вариант2) 0
Скопировать строку с номером, с лидирующими нулями, в числовом поле (с форматом без групп, без группировки), и вернуть(скопировать) обратно в строковом поле с номером. Возвращает без нулей.
Посмотреть все результаты поиска похожих
Комментарии
sergson
18.07.2015 13:38Комментарий: 1
sergson

Еще я переделал если нужно получить ТипЦены из Контрагента. Сам мучался неделю, пока через Сервер не написал))

Код 1C v 8.3
 

&НаКлиенте
Процедура ТоварНоменклатураПриИзменении(Элемент)
СтрокаТабличнойЧасти = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные;
Номенклатура = СтрокаТабличнойЧасти.Номенклатура;
ТипЦен = ПолучитьТипЦены();
ТекДата = Объект.Дата;
СтрокаТабличнойЧасти.Цена = ПолучитьЦену(Номенклатура, ТипЦен, ТекДата);
КонецПроцедуры


&НаСервере
Функция ПолучитьЦену(Номенклатура, ТипЦен, ТекДата) Экспорт
Отбор = Новый Структура;
Отбор.Вставить("Номенклатура",Номенклатура);
Отбор.Вставить("ТипЦены",ТипЦен);
ЦенаТовара = РегистрыСведений.ЦеныНоменклатуры.ПолучитьПоследнее(ТекДата,Отбор);
Возврат ЦенаТовара.Цена;
КонецФункции


Функция ПолучитьТипЦены() Экспорт
Значение = Объект.Контрагент.ТипЦены;
Возврат Значение;
КонецФункции
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.