helpf.pro
Регистрация
 +2 
Распечатать

Как установить цену из РегистраСведений на дату создания документа

Код 1C v 8.3
 

&НаКлиенте
Процедура ТоварНоменклатураПриИзменении(Элемент)
СтрокаТабличнойЧасти = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные;
Номенклатура = СтрокаТабличнойЧасти.Номенклатура;
ТипЦен = ЭтаФорма.ТипЦен;
ТекДата = Объект.Дата;
СтрокаТабличнойЧасти.Цена = ПолучитьЦену(Номенклатура, ТипЦен, ТекДата);
КонецПроцедуры


&НаСервере
Функция ПолучитьЦену(Номенклатура, ТипЦен, ТекДата) Экспорт
Отбор = Новый Структура;
Отбор.Вставить("Номенклатура",Номенклатура);
Отбор.Вставить("ТипЦены",ТипЦен);
ЦенаТовара = РегистрыСведений.ЦеныНоменклатуры.ПолучитьПоследнее(ТекДата,Отбор);
Возврат ЦенаТовара.Цена;
КонецФункции


Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 2703
 +2 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Посмотреть все результаты поиска похожих
Комментарии
sergson
18.07.2015 13:38Комментарий: 1
sergson

Еще я переделал если нужно получить ТипЦены из Контрагента. Сам мучался неделю, пока через Сервер не написал))

Код 1C v 8.3
 

&НаКлиенте
Процедура ТоварНоменклатураПриИзменении(Элемент)
СтрокаТабличнойЧасти = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные;
Номенклатура = СтрокаТабличнойЧасти.Номенклатура;
ТипЦен = ПолучитьТипЦены();
ТекДата = Объект.Дата;
СтрокаТабличнойЧасти.Цена = ПолучитьЦену(Номенклатура, ТипЦен, ТекДата);
КонецПроцедуры


&НаСервере
Функция ПолучитьЦену(Номенклатура, ТипЦен, ТекДата) Экспорт
Отбор = Новый Структура;
Отбор.Вставить("Номенклатура",Номенклатура);
Отбор.Вставить("ТипЦены",ТипЦен);
ЦенаТовара = РегистрыСведений.ЦеныНоменклатуры.ПолучитьПоследнее(ТекДата,Отбор);
Возврат ЦенаТовара.Цена;
КонецФункции


Функция ПолучитьТипЦены() Экспорт
Значение = Объект.Контрагент.ТипЦены;
Возврат Значение;
КонецФункции
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.