helpf.pro
Регистрация
 0 
Распечатать

Веб браузер в 1С используя поле HTML документа

Настраивал клиенту CRM, он захотел - чтобы панель управления сайтом была в 1С. Хочет - делаем: 

Обработка Веб браузер проста, состоит из поля HTML документа и 20 строчек кода:

Код команд: 

Код 1C v 8.3
 &НаКлиенте
Процедура Команда1(Команда)
Объект.HTML = Адрес;
КонецПроцедуры


&НаКлиенте
Процедура Назад(Команда)
Элементы.HTML.Назад();
КонецПроцедуры

&НаКлиенте
Процедура АдресОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
Объект.HTML = Текст; Адрес = Текст; 
КонецПроцедуры

&НаКлиенте
Процедура HTMLДокументСформирован(Элемент)
Адрес = Элемент.Документ.url;
КонецПроцедуры

Скачать обработку для 1С 8.3.7 : WebBrauzer.rar 

Поле HTML документа - Это Internet Explorer в режиме совместимости IE7, и к сожалению, большинство сайтов уже ориентированы на современные браузеры и при открытии возникает ошибка:

Но у сайтов, владельцы которых позаботились о совместимости, все открывается без ошибок, например: этот https://helpf.pro или http://www.rbc.ru

Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 15098
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 10
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 40
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Посмотреть все результаты поиска похожих
Комментарии
darkoder
27.09.2017 13:58Комментарий: 3
darkoder
для того чтобы перевести 1с в режим совместимости с ie11 надо в реестре в ветке[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]создать параметр dword с именем 1cv8.exe и десятичным значением 11001

а так же создать 1cv8c.exe и 1cv8s.exe м такими же параметрами

http://sikuda.ru/archives/10

darkoder
27.09.2017 13:57Комментарий: 2
darkoder

для того чтобы перевести 1с в режим совместимости с ie11 надо в реестре в ветке

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]

создать параметр dword с именем 1cv8.exe и десятичным значением 11001

а так же создать 1cv8c.exe и 1cv8s.exe м такими же параметрами

http://sikuda.ru/archives/10

darkoder
27.09.2017 13:56Комментарий: 1
darkoder

для того чтобы перевести 1с в режим совместимости с ie11 надо в реестре в ветке

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]

создать параметр dword с именем 1cv8.exe и десятичным значением 11001

а так же создать 1cv8c.exe и 1cv8s.exe м такими же параметрами

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.