helpf.pro
Регистрация
 +3 
Распечатать

Как узнать текущие релизы 7.7 для Украины

Код 1C v 7.x
 

Функция ПолучитьВерсии()
Перем Url, HtmlTab, Строк, Р, НомСтроки, Таб, Версия, ДатаВремя;
ОчиститьОкноСообщений();
СтатусВозврата(0);
Url = "http://www.1c.ru/ukraina/support/release.jsp?time=" + _GetPerformanceCounter();
Сообщить(Url);
IE = СоздатьОбъект("InternetExplorer.Application");
IE.Navigate(Url);
Пока (IE.readyState <> 4) Или (IE.Busy = -1) Цикл
Состояние("Получение страницы... " + Url);
КонецЦикла; 
HtmlTab = IE.Document.getElementsByTagName("table").item(4).rows(0).cells(4).childNodes.item(10);
Строк = HtmlTab.rows.length;
Таб = СоздатьОбъект("ТаблицаЗначений");
Таб.НоваяКолонка("Версия" , "Строка");
Таб.НоваяКолонка("Дата" , "Дата");
Таб.НоваяКолонка("Время" , "Строка");
Таб.НоваяКолонка("Продукт" , "Строка");
Для НомСтроки = 1 По Строк Цикл
Р = HtmlTab.rows(НомСтроки - 1);
Если Р.cells.length <> 3 Тогда
Продолжить;
КонецЕсли;
Версия = Р.cells(2).innerText;
Если Найти(Версия, "7.70.") = 0 Тогда
Продолжить;
КонецЕсли;
ДатаВремя = Р.cells(0).innerText;
Таб.НоваяСтрока();
Таб.Дата = ДатаВремя;
Таб.Время = Сред(ДатаВремя, 12);
Таб.Продукт = Р.cells(1).innerText;
Таб.Версия = Версия;
КонецЦикла;
Таб.Сортировать("Дата-,Время-");
Возврат Таб;
КонецФункции


Разместил:   Версии: | 7.x |  Дата:   Прочитано: 2126
 +3 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Как обновить или откатить релиз программы? 1
Вопрос: Была проблема с расчетами в конфигурации, поэтому обновил 2.5.23.4 на 2.5.24.2 (кажется, она тестовая была). А вот теперь не могу обновить на 2.5.24.4, т.к. при обновлении сообщается, что обновляются только релизы 2.5.23.4 и...
Обновление платформы на клиентских машинах и восстановление списка информационных баз пользователей 0
Периодически сталкиваюсь с проблемой обновления платформы на клиентских машинах, + периодически пользователи удаляют, изменяют или добавляют какие-то новые информационные БД. В случае 8.2 новые релизы платформы стали...
Процедура вычисляет количество лет, месяцев и дней между двумя датами 0
// Процедура вычисляет количество лет, месяцев и дней между двумя датами // // Параметры // Дата1 – дата, первая дата (более поздняя, часто текущая, стаж определяется по состоянию на эту дату) // Дата2 – дата, вторая дата...
Резервирование центрального кластера 1С и "Безопасное" обновление платформы 1С 0
Тем, кто не сталкивался с 8.2 и всеми проблемами, особенно ранних версий платформы на системах с большим количеством пользователей меры, описанные в этой статье окажутся избыточными. Но все действия продиктованы только...
Посмотреть все результаты поиска похожих
Комментарии
Ruban_Igor
07.01.2016 01:59Комментарий: 1
Ruban_Igor

Виноват....Ну конечно же нужно добавить: IE = 0;

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.