helpf.pro
Регистрация
 +1 
Распечатать

запрос ФИО руководителя полностью, сделал на основе оригинальной функции

Код 1C v 8.2 УП
 Функция ОтветственныеЛицаОрганизации(Организация, ДатаСреза, Исполнитель = Неопределено) Экспорт

    Результат = Новый Структура("Руководитель, РуководительДолжность, ГлавныйБухгалтер, Кассир");
    
    Если Организация <> Неопределено тогда

          ЗапросПоЛицам = Новый Запрос();
        ЗапросПоЛицам.УстановитьПараметр("Организация", Организация);
        ЗапросПоЛицам.УстановитьПараметр("ДатаСреза",   ДатаСреза);
        ЗапросПоЛицам.Текст = "
        |ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    ОтветственныеЛицаОрганизацииСрезПоследних.ОтветственноеЛицо,
        |    ОтветственныеЛицаОрганизацииСрезПоследних.Должность.Наименование КАК Должность,
        |    ВЫБОР КОГДА (ФИОФизЛицСрезПоследних.ФизЛицо) ЕСТЬ NULL  ТОГДА ОтветственныеЛицаОрганизацииСрезПоследних.ФизическоеЛицо.Наименование ИНАЧЕ ФИОФизЛицСрезПоследних.Фамилия + ВЫБОР КОГДА (ФИОФизЛицСрезПоследних.Имя) <> """" ТОГДА "" "" + (ФИОФизЛицСрезПоследних.Имя) ИНАЧЕ """" КОНЕЦ + ВЫБОР КОГДА (ФИОФизЛицСрезПоследних.Отчество) <> """" ТОГДА "" "" + (ФИОФизЛицСрезПоследних.Отчество) ИНАЧЕ """" КОНЕЦ КОНЕЦ КАК ФИОПолное
        |ИЗ
        |    РегистрСведений.ОтветственныеЛицаОрганизации.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница =Организация) КАК ОтветственныеЛицаОрганизацииСрезПоследних
        |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ФИОФизЛиц.СрезПоследних(&ДатаСреза, ФизЛицо ССЫЛКА Справочник.ФизическиеЛица) КАК ФИОФизЛицСрезПоследних
        |        ПО ОтветственныеЛицаОрганизацииСрезПоследних.ФизическоеЛицо = ФИОФизЛицСрезПоследних.ФизЛицо";
                
        Выборка = ЗапросПоЛицам.Выполнить().Выбрать();
                
        Пока Выборка.Следующий() Цикл

              Если Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизации.Руководитель Тогда
                Результат.Руководитель            = Выборка.ФИОПолное;
                Результат.РуководительДолжность   = Выборка.Должность;

              ИначеЕсли Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизации.ГлавныйБухгалтер Тогда
                Результат.ГлавныйБухгалтер        = Выборка.ФИОПолное;

              ИначеЕсли Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизации.Кассир Тогда
                Результат.Кассир                  = Выборка.ФИОПолное;

              КонецЕсли;

          КонецЦикла;
    КонецЕсли;

    Возврат Результат;

КонецФункции // ОтветственныеЛицаОрганизации()
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 1969
 +1 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Внутреннее устройство PostgreSQL, в помощь администраторам 1С 0
Понимание архитектуры используемой СУБД очень важно для правильной эксплуатации, но местами переоценено: администратору, DevOps-специалисту или разработчику прикладных систем вовсе необязательно знать подробности...
Выгрузка / Загрузка данных посредством XML файлов? 0
В основе работы с XML-файлами лежит технология доступа SAX, которая осуществляет считывание по одному тегу. Для этого существует два типа данных – ЗаписьXML и ЧтениеXML . Запись данных справочника в XML-файл: Запись = Новый...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.