helpf.pro
Регистрация
 0 
Распечатать

Преобразование ТаблицыЗначений во временную таблицу

Код 1C v 8.х
 Процедура ПреобразоватьТЗвТЗсОписаниемТипов(ТЗ)
ТипизированнаяТЗ = Новый ТаблицаЗначений;
    Для й=1 По Тз.Количество() Цикл ТипизированнаяТЗ.Добавить(); //Создаем строки
    КонецЦикла;    
    
    ДЗТипов = Новый ДеревоЗначений;
    ДЗТипов.Колонки.Добавить("ИмяКолонки");
    ДЗТипов.Колонки.Добавить("ТипЗначений");
    
    Для Каждого Колонка из Тз.Колонки Цикл
        СтрокаКолонки = ДЗТипов.Строки.Добавить();
        СтрокаКолонки.ИмяКолонки = Колонка.Имя;
        
        ТекСТрокаТипа = СтрокаКолонки.Строки.Добавить();
        ТекСТрокаТипа.ИмяКолонки = Колонка.Имя; //Заполняется для красоты
        ТекСТрокаТипа.ТипЗначений = ТипЗнч(тз[0][Колонка.Имя]);
        Для Каждого СтокаТЗ из Тз Цикл
            ТекТип = ТипЗнч(СтокаТЗ[Колонка.Имя]);
            Если НЕ ТекТип = ТекСТрокаТипа.ТипЗначений Тогда
                Если СтрокаКолонки.Строки.Найти(ТекТип, "ТипЗначений")=Неопределено Тогда
                    ТекСТрокаТипа = СтрокаКолонки.Строки.Добавить();
                    ТекСТрокаТипа.ИмяКолонки = Колонка.Имя;//Заполняется для красоты
                    ТекСТрокаТипа.ТипЗначений = ТекТип;
                КонецЕслИ;
            КонецЕслИ;
        КонецЦикла;
        
        МассивТипов = СтрокаКолонки.Строки.ВыгрузитьКолонку("ТипЗначений");
        ТипизированнаяТЗ.Колонки.Добавить(Колонка.Имя, Новый ОписаниеТипов(МассивТипов),Колонка.Заголовок);
        ТипизированнаяТЗ.ЗагрузитьКолонку(Тз.ВыгрузитьКолонку(Колонка),Колонка.Имя);
    КонецЦикла;
КонецПроцедуры

Источник

Разместил:   Версии: |  Дата:   Прочитано: 894
 0 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
HTML5 Canvas в 1С 8.3 или Google нам поможет 0
Добрался я для написания маленьких тестов для 1С в плане web графики. Версии 1С 8.2.61 и 8.3.3.641. Зайдем на http://www.w3schools.com/html/html5_canvas.asp и перенесем примеры в обработку 1С. Скачать обработку: Результаты не радуют. 1С в Intern
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.