helpf.pro
Регистрация
 +3 
Распечатать

Как найти документ по уникальному идентификатору через com соединение?

Потребовалось написать небольшую синхронизацию данных в дополнении к стандартной УТ-БП, нужно по уникальному идентификатору искать документы:

Стандартное Соединение.Справочники.Номенклатура.ПолучитьСсылку(УИ);

Выдает ошибку {Форма.Форма.Форма(301)}: Ошибка при вызове метода контекста (ПолучитьСсылку): Произошла исключительная ситуация: Несоответствие типов (параметр номер '1')

Нужно уникальный идентификатор создавать в com: Соединение.Справочники.Номенклатура.ПолучитьСсылку(Соединение.NewObject("УникальныйИдентификатор",Строка(УИ)));

Рабочий пример:

Код 1C v 8.3
 

&НаСервере

Функция ПодключитьБазуНаСервере(Соединение = "")

Объект.ФайловаяБазаДанных=Ложь;

Объект.Сервер="srv1с";

Объект.База="buh";

Объект.ИмяПользователя="Obmen";

Объект.Пароль="1qaz";

// Подключение к 1С

Если Объект.ФайловаяБазаДанных Тогда

СтрокаПодключения = "file='" + Объект.ПутьКБазе + "'; usr='" + Объект.ИмяПользователя + "'; pwd='" + Объект.Пароль + "';";

Иначе

СтрокаПодключения = "srvr='" + Объект.Сервер + "'; ref='" + Объект.База + "'; usr='" + Объект.ИмяПользователя + "'; pwd='" + Объект.Пароль + "';";

КонецЕсли;

Попытка

V8 = Новый COMObject("V83.COMConnector");

Соединение = V8.Connect(СтрокаПодключения);

ЕстьСоединение = Истина;

Исключение

ЕстьСоединение = Ложь;

Сообщить(ОписаниеОшибки());

КонецПопытки;

Возврат Соединение;

КонецФункции

&НаСервере

Процедура ОбновитьДанныеПлатежейНаСервере()

Соединение = ПодключитьБазуНаСервере();

Запрос = Новый Запрос;

Запрос.Текст =

"ВЫБРАТЬ

|ПоступлениеБезналичныхДенежныхСредствРасшифровкаПлатежа.Ссылка КАК Ссылка,

|ПоступлениеБезналичныхДенежныхСредствРасшифровкаПлатежа.ОснованиеПлатежа КАК ОснованиеПлатежа,

|ПоступлениеБезналичныхДенежныхСредствРасшифровкаПлатежа.Сумма КАК Сумма

|ИЗ

|Документ.ПоступлениеБезналичныхДенежныхСредств.РасшифровкаПлатежа КАК ПоступлениеБезналичныхДенежныхСредствРасшифровкаПлатежа

|ГДЕ

|НЕ ПоступлениеБезналичныхДенежныхСредствРасшифровкаПлатежа.ОснованиеПлатежа ССЫЛКА Документ.ЗаказКлиента";

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

УИД = ВыборкаДетальныеЗаписи.Ссылка.УникальныйИдентификатор();

СсылкаНаДок = Соединение.Документы.ПоступлениеНаРасчетныйСчет.ПолучитьСсылку(Соединение.NewObject("УникальныйИдентификатор",Строка(УИД)));

//Сообщить(СсылкаНаДок.Номер);

Для каждого СтрокаИсточник Из СсылкаНаДок.РасшифровкаПлатежа Цикл

//Сообщить("Счет: "+Строка(СтрокаИсточник.СчетНаОплату.Номер));

УИД = Соединение.String(СтрокаИсточник.СчетНаОплату.УникальныйИдентификатор());

текДок= Документы.ЗаказКлиента.ПолучитьСсылку(Новый УникальныйИдентификатор(УИД));

Если ЗначениеЗаполнено(текДок) Тогда

Сообщить(текДок);

текОбъект=ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();

текОбъект.РасшифровкаПлатежа[0].ОснованиеПлатежа= текДок;

текОбъект.РасшифровкаПлатежа[0].Заказ= текДок;

текОбъект.Записать(РежимЗаписиДокумента.Проведение);

КонецЕсли;

КонецЦикла;

КонецЦикла;

КонецПроцедуры

&НаКлиенте

Процедура ОбновитьДанныеПлатежей(Команда)

ОбновитьДанныеПлатежейНаСервере();

КонецПроцедуры

Разместил:   Версии: | 8.2 УП | 8.3 |  Дата:   Прочитано: 27986
 +3 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 8
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код заполнения ТЧ НаСервере П
10060 (0x0000274C): Попытка установить соединение была безуспешной 24
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через терминал, а еще у нее свой ноутбук и
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 51
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
1C и Google Maps 21
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во время решения задачи было реш
1C: Enterprise Development Tools 52
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.