helpf.pro
Регистрация
 +3 
Распечатать

Как подключиться (присоединится) к базе 1С 8 через СОМ

Код 1C v 8.х
 //Пример 1 
v8 = CreateObject("V8.COMConnector");
//Строку подключения можно получить так:
Если ФайловаяБазаДанных Тогда
СтрокаПодключения = "file='" + КаталогБазыДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "';";
Иначе
СтрокаПодключения = "srvr='" + Сервер + "'; ref='" + БазаДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "';";
КонецЕсли;
Попытка
//Соединение = V8.Connect("Usr=""admin"";Pwd="""";File=""\\srvr\1C\V8\UPP""");
Соединение = V8.Connect(СтрокаПодключения);
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;


//Пример 2
Функция ОткрытьСоединение(ОписаниеОшибки) Экспорт
СтрокаПодключения = СформироватьСтрокуПодключения();
Connector = Новый COMОбъект("V8.ComConnector");

Попытка
DataSource = Connector.Connect(СтрокаПодключения);
Исключение
ОписаниеОшибки = ОписаниеОшибки();
КонецПопытки;

Если DataSource = Неопределено И ПустаяСтрока(ОписаниеОшибки) Тогда
ОписаниеОшибки = "Неизвестная ошибка подключения к 1С:Предприятие 8.0";
КонецЕсли;

Если Не ПустаяСтрока(ОписаниеОшибки) Тогда
DataSource = Неопределено;
Connector = Неопределено;
КонецЕсли;

Возврат DataSource;
КонецФункции

Функция СформироватьСтрокуПодключения()

СтрокаПодключения = "";
Если ЭтоСервер Тогда
СтрокаПодключения = СтрокаПодключения + "Srvr=" + Сервер + ";Ref=" + Имя + ";";
Иначе
СтрокаПодключения = СтрокаПодключения + "File=""" + Сервер + """;";
КонецЕсли;
СтрокаПодключения = СтрокаПодключения + ?(ПустаяСтрока(Пользователь), "", "Usr=""" + Пользователь + """;");
СтрокаПодключения = СтрокаПодключения + ?(ПустаяСтрока(Пароль), "", "Pwd=""" + Пароль + """;");

Возврат СтрокаПодключения;
КонецФункции

Посмотрите еще ответ на вопрос: Как определить Информационная База файловая или SQL?
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 37253
 +3 
Распечатать
Возможно, вас также заинтересует
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Авто добавление обработки в справочник Внешних обработок 0
Чтобы не изменять типовую конфигурацию приходится использовать типовой механизм внешних печатных форм и обработок. Данный код проверяет - добавлена ли открываемая обработка в конфигурацию, если нет - задает вопрос и...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Посмотреть все результаты поиска похожих
Комментарии
MasterOL
28.02.2012 01:00Комментарий: 2
MasterOL
Спасибо
Onotoley
03.02.2012 15:11Комментарий: 1
Onotoley
Доброго времени суток!
Обработка работала через подключение, как приведено в этом примере. Все базы были на одном сервере в одном кластере. Разнес базы по разным кластерам - все работает нормально. Но! При обращении к базе, которая находится на нестандартном кластере, вываливает ошибку.
Например:
Сервер 1C_SERVER, база BASE. Строка подключения вида "srvr=1C_SERVER;ref=BASE; и т.д."
В другом кластере (его порт 1641):
Сервер 1C_SERVER:1641, база BASE1. Строка подключения вида "srvr=1C_SERVER:1641;ref=BASE1; и т.д."

Во втором случае происходит ошибка ) Кто сталкивался с подобным?
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.