helpf.pro
Регистрация
 0 
Распечатать

Копирование подчиненных элементов справочника из группы Источник в группу Цель

Код 1C v 7.x
 
Справ=СоздатьОбъект("Справочник.Задания");
Справ2=СоздатьОбъект("Справочник.Задания");
Справ.ИспользоватьВладельца(Цель);
Справ2.ИспользоватьВладельца(Источник);
Справ.ИспользоватьДату(НаДату);
Справ2.ИспользоватьДату(НаДату);

Справ2.ВыбратьЭлементы();
Пока Справ2.ПолучитьЭлемент()>0 Цикл
Справ.Новый();
Справ.Записать();
МетаСправочник=Метаданные.Справочник(Справ.Вид());
Для Счетчик=1 По МетаСправочник.Реквизит() Цикл
МетаРеквизит=МетаСправочник.Реквизит(Счетчик);
Идентификатор=Строка(МетаРеквизит.Идентификатор);
Значенице=Справ2.ПолучитьАтрибут(Идентификатор);
Справ.УстановитьАтрибут(Идентификатор,Значенице);
КонецЦикла;
Справ.Записать();
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5674
 0 
Распечатать
Возможно, вас также заинтересует
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
HTML5 Canvas в 1С 8.3 или Google нам поможет 0
Добрался я для написания маленьких тестов для 1С в плане web графики. Версии 1С 8.2.61 и 8.3.3.641. Зайдем на http://www.w3schools.com/html/html5_canvas.asp и перенесем примеры в обработку 1С. Скачать обработку: Результаты не радуют. 1С в Intern
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.