helpf.pro
Регистрация
 0 
Распечатать

Пример реализации контроля ошибок при сохранение данных на дискету

При сохранении данных на дискету нужно организовать контроль ошибок, в частности проверку наличия носителя в дисководе. Сделать это можно следующим образом:

Код 1C v 7.x
 Выгружаем = 0;
Попытка
Если СтрДлина(ФС.НайтиПервыйФайл("a:\*.*")) > 0 Тогда
Если Вопрос("Дискета содержит информацию. Продолжить?","Да+Нет")= "Да" Тогда
Выгружаем = 1;
КонецЕсли;
Иначе
Выгружаем = 1;
КонецЕсли;
Если Выгружаем = 1 Тогда
//процедура сохранения данных
КонецЕсли;
Исключение
Предупреждение("Ошибка записи. Проверьте доступность носителя. (" + ОписаниеОшибки() + ")");
КонецПопытки;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6300
 0 
Распечатать
Возможно, вас также заинтересует
1C медленно работает по сети с базой на SQL Server 11
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1C: Enterprise Development Tools 37
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
В отчет не попадают данные за последний день… Как исправить? 0
Пользователь выбрал период формирования отчета с 1июля по 31. Почему при формировании отчета в него не попадают данные за 31 число? На самом деле, это одна из самых распространенных ошибок при разработке отчетов. В 1С 8.х...
Веб браузер в 1С используя поле HTML документа 0
Настраивал клиенту CRM, он захотел - чтобы панель управления сайтом была в 1С. Хочет - делаем: Обработка Веб браузер проста, состоит из поля HTML документа и 20 строчек кода: Код команд: НаКлиенте Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.