helpf.pro
Регистрация
 +1 
Распечатать

Прогресс бар в строке состояния

Для наглядного представления продолжительного процесса выполнения обработки данных можно реализовать строку прогресса в строке состояния при помощи псевдографики.
Код 1C v 7.x
 //Пример процедуры обработки таблицы значений ТЗ
//Размер прогрессора задан в 20 символов (5%)
Процедура ОБработкаДанных()
РазмерИндикатора = ТЗ.КоличествоСтрок();
Индикатор = "";
Для А = 1 По 20 Цикл
Индикатор = Индикатор + " ";
КонецЦикла;
Счетчик = 0;
//Текст обработки строк ТЗ
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолуичтьСтроку() = 1 Цикл
Счетчик = Счетчик + 1;
//Обработка строки
Показатель = Цел(Счетчик/РазмерИндикатора * 100);
Если Цел(Показатель/5) = Показатель/5 Тогда
Индикатор = "";
Для А = 1 По 20 Цикл
Индикатор = Индикатор + ?(А<=Показатель/5,Симв(127)," ");
КонецЦикла;
Состояние(Индикатор + "| Анализ адресов; " + Показатель + "%");
КонецЕсли;
КонецЦикла;
КонецПроцедуры


Код 1C v 7.x
 // ПрогрессБар в строке состояния. Маленький, шустренький
Процедура глПрогрессор(Сообщение,Всего,Текущ) Экспорт
Если Всего>0 Тогда
Процент=Цел(Текущ/Всего * 100);
Если Процент > Цел((Текущ-1)/Всего * 100) Тогда
Состояние(Сообщение + ": "+Формат(Процент,"Ч(0)2")+"% "+СтрЗаменить(Формат("","С"+Мин(99,Процент))," ","l")+СтрЗаменить(Формат("","С"+Мин(99,99-Процент))," ","'")+"l");
КонецЕсли;
КонецЕсли;
КонецПроцедуры

// Вот пример использования:
Для ин=1 По 100000 Цикл
глПрогрессор("Тест",100000,ин);
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 11749
 +1 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Посмотреть все результаты поиска похожих
Комментарии
E_Migachev
31.05.2010 09:16Комментарий: 2
E_Migachev
ShamanNet, можно, этот код в 8.1 работает!
ShamanNet
31.05.2010 08:34Комментарий: 1
ShamanNet
А можно ли прогрессбар вывести в строку состояния для 8.1?
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.