helpf.pro
Регистрация
 0 
Распечатать

Создание списка всех видов расчетов

Для включения всех видов расчетов в произвольный список значений без использования перебора групп видов расчетов можно использовать функцию Шаблон().

Код 1C v 7.x
 //Функция присвоения значения
Функция ПолучениеВР(ВР,Объект)
ВР = Объект;
Возврат "";
КонецФункции

//Ниже приведен цикл перебора видов расчетов
сзВидыРасчетов = СоздатьОбъект("СписокЗначений");
Для А = 1 По Метаданные.ВидРасчета() Цикл
текВР = Метаданные.ВидРасчета(А);
Шаблон("[ПолучениеВР(ВР,"+текВР.ПолныйИдентификатор()+")]");
Если ПустаяСтрока(текВР.Синоним) = 1 Тогда
стрВР = текВР.Идентификатор;
Иначе
стрВР = текВР.Синоним;
КонецЕсли;
сзВидыРасчетов.ДобавитьЗначение(ВР,стрВР);
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5390
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 9
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 26
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Ввод договоров ГПХ в ЗУП (счет 76) 7
Часто меня спрашивают: Как правильно отразить договор ГПХ в ЗУП? Ниже небольшая, последовательная инструкция: Прием на работу Сведения о физическом лице, выполняющем работы по договору подряда, должны быть внесены...
Ввод дополнительного ежегодного отпуска 1
Вид расчета, используемый для начисления оплаты дополнительного ежегодного отпуска , описывается в плане видов расчета Основные начисления организаций . Новый вид расчета удобнее создать копированием...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.