helpf.pro
Регистрация
 0 
Распечатать

Выгрузка используемых видов расчетов в таблицу значений

Код 1C v 7.x
 ТЗВидыРасчётов = Новый ТаблицаЗначений;
ТЗВидыРасчётов.Колонки.Добавить("ВидРасчёта");

ЖРЗарплата = v7.CreateObject("ЖурналРасчетов.Зарплата");
ЖРЗарплата.ВыбратьЗаписи(НачДата,КонДата);
Пока ЖРЗарплата.ПолучитьЗапись() = 1 Цикл
СтрВидыРасчётов = ТЗВидыРасчётов.Добавить();
СтрВидыРасчётов.ВидРасчёта = ЖРЗарплата.ВидРасч.Наименование;
КонецЦикла;

ЖРДополнительный = v7.CreateObject("ЖурналРасчетов.Дополнительный");
ЖРДополнительный.ВыбратьЗаписи(НачДата,КонДата);
Пока ЖРДополнительный.ПолучитьЗапись() = 1 Цикл
СтрВидыРасчётов = ТЗВидыРасчётов.Добавить();
СтрВидыРасчётов.ВидРасчёта = ЖРДополнительный.ВидРасч.Наименование;
КонецЦикла;

ЖРНалогиСФОТ = v7.CreateObject("ЖурналРасчетов.НалогиСФОТ");
ЖРНалогиСФОТ.ВыбратьЗаписи(НачДата,КонДата);
Пока ЖРНалогиСФОТ.ПолучитьЗапись() = 1 Цикл
СтрВидыРасчётов = ТЗВидыРасчётов.Добавить();
СтрВидыРасчётов.ВидРасчёта = ЖРНалогиСФОТ.ВидРасч.Наименование;
КонецЦикла;

ЖРСтраховыеВзносы = v7.CreateObject("ЖурналРасчетов.СтраховыеВзносы");
ЖРСтраховыеВзносы.ВыбратьЗаписи(НачДата,КонДата);
Пока ЖРСтраховыеВзносы.ПолучитьЗапись() = 1 Цикл
СтрВидыРасчётов = ТЗВидыРасчётов.Добавить();
СтрВидыРасчётов.ВидРасчёта = ЖРСтраховыеВзносы.ВидРасч.Наименование;
КонецЦикла;


Написал IKSparrow
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5930
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 9
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 3
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 1
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.