helpf.pro
Регистрация
 0 
Распечатать

У текущего пользователя нет ролей, допускающих запуск информационной базы!

В стандартных конфигурациях есть такая проверка, например :
В ЗУПе у пользователя должна быть доступна роль "Пользователь" или "ПолныеПрава"
В Бухгалтерии у пользователя должна быть доступна роль "Бухгалтер" или "ПолныеПрава"

А проверяет это кусок кода вида:
Код 1C v 8.х
 
// Функция проверяет установлены ли у пользователя роли,
// с которыми можно запускать конфигурацию
Функция ЕстьДоступныеПраваДляЗапускаКонфигурации() Экспорт

Возврат РольДоступна("ПолныеПрава")
ИЛИ РольДоступна("Пользователь")
ИЛИ ЕстьРолиБезОграниченияПравДоступаНаУровнеЗаписей();

КонецФункции

//.....
// а ниже
Если НЕ ЕстьДоступныеПраваДляЗапускаКонфигурации() Тогда
Отказ = Истина;
#Если Клиент Тогда
Предупреждение("У текущего пользователя нет ролей, допускающих запуск информационной базы!", 10, "Недостаточно прав доступа");
#КонецЕсли
КонецЕсли;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 17425
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 40
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
1C: Enterprise Development Tools 49
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 11
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который выпускает компания 1С . Что такое
COM-подключение к базе 7.7 из .NET, .NET Core 0
Инсталяция: dotnet add package sabatex.V1C77 или добавить через NUGET пакет sabatex.V1C77. Добавить пространство имен: using sabatex.V1C77; пример использованя: ---C# static void Main(string args) { // создаем строку соединен
COM-подключение к базе 7.7 из 8.2 1С 6
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе=" D:ВашаБаза1с77" ; Пользователь=
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.