helpf.pro
Регистрация
 0 
Распечатать

Запись движений Приход или Расход в регистр остатков

Методы ДвижениеПриход и ДвижениеРасход, доступны только при проведении документа в предопределенной процедуре ОбработкаПроведения.

Код 1C v 7.x
  ВыбратьСтроки(); //Переберем строки документа
Пока ПолучитьСтроку() > 0 Цикл
Регистр.ТовЗап.ПривязыватьСтроку(НомерСтроки); //Записать НомерСтроки документа в движении регистра.
Регистр.ТовЗап.ДвижениеПриход(Склад, Товар, Количество, Стоимость);
КонецЦикла;
//или
Процедура ОбработкаПроведения()
строк = КоличествоСтрок();
ВыбратьСтроки(); //Переберем строки документа
Пока ПолучитьСтроку()=1 Цикл
Сообщить("Склад=" + Склад + " Получатель=" + Получатель+ " Товар="+Товар+" кол-во="+Количество+" сумма="+Количество*Цена);
Регистр.Остатки_товаров.ДвижениеРасход(Товар,Склад,Получатель,Количество,Количество*Цена);
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6037
 0 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
rphost занимает память и грузит процессор 12
У многих возникают проблемы с rphost.exe, разного вида: rphost занимает всю память rphost грузит процессор rphost жрет память причем 1С даже на запущена, а в диспетчере следующее: ежеминутно расчет на 2-3 мегабайта. Как быть и...
v7plus.dll - отсутствует CLSID либо отсутствует интерфейс llnitDone 0
При выгрузке отчетности в 1С 7.7 программа ругается на v7plus.dll и указывает, что отсутствует интерфейс llritDone. Что делать? 1) Поудалять нафиг все v7plus.dll из каталогов ИБ и папок пользователей 2) Оставить только в bin каталоге и...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.