helpf.pro
Регистрация
 +2 
Распечатать

Функция преобразовавает Фамилия Имя Отчество в Фамилия И. О.

Код 1C v 8.х
 
Функция ФамилияИО(ПолнИмя) Экспорт
ПервПроб = Найти(ПолнИмя," ");
Если ПервПроб=0 Тогда
Возврат ПолнИмя;
Иначе
Фамилия = Лев(ПолнИмя,ПервПроб);
ИО = Сред(ПолнИмя,ПервПроб+1);
ИО = СокрЛ(ИО);
Имя = Лев(ИО,1)+".";
ВтПроб = Найти(ИО," ");
Если ВтПроб=0 Тогда
Возврат Фамилия+Имя;
Иначе
Возврат Фамилия+Имя+" "+Лев(СокрЛ(Сред(ИО,ВтПроб+1)),1)+".";
КонецЕсли;
КонецЕсли;
КонецФункции

//Пример обращения
Текст = "Андреева Алла Александровна";
Сообщить(ФамилияИО(Текст)); //Выведет - Андреева А. А.


Код 1C v 8.х
 Функция ИОФамилия(Сотрудник) Экспорт
Пока Найти(Сотрудник, " ") <> 0 Цикл
Сотрудник = СтрЗаменить(Сотрудник," "," ");
КонецЦикла;

Сотрудник = СтрЗаменить(Сотрудник," ",Символы.ПС);
Возврат Лев(СтрПолучитьСтроку(Сотрудник,2),1) + ". "+Лев(СтрПолучитьСтроку(Сотрудник,3),1) + ". "+СтрПолучитьСтроку(Сотрудник,1);
КонецФункции


Код 1C v 7.x
 Функция ФамилияИО(ПолнИмя) Экспорт
// позиция первого пробела
ПервПроб = Найти(ПолнИмя," ");
Если ПервПроб=0 Тогда
Возврат ПолнИмя;
Иначе
Фамилия = Лев(ПолнИмя,ПервПроб);
ИО = Сред(ПолнИмя,ПервПроб+1);
ИО = СокрЛ(ИО);
Имя = Лев(ИО,1)+".";
// позиция второго пробела
ВтПроб = Найти(ИО," ");
Если ВтПроб=0 Тогда
Возврат Фамилия+Имя;
Иначе
Возврат Фамилия+Имя+" "+Лев(СокрЛ(Сред(ИО,ВтПроб+1)),1)+".";
КонецЕсли;
КонецЕсли;
КонецФункции


Существует запрет на коноплю из-за политического и социального давления, его терпимость. Но можно семена конопли купить - в последнее время, ее декриминализацию стали продвигать ради для рекреационного и медицинского использования.
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 38187
 +2 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 8
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код заполнения ТЧ НаСервере П
10060 (0x0000274C): Попытка установить соединение была безуспешной 24
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через терминал, а еще у нее свой ноутбук и
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 50
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
1C медленно работает по сети с базой на SQL Server 22
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для взаимодействия 1С с SQL Server. П
1C: Enterprise Development Tools 52
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Посмотреть все результаты поиска похожих
Комментарии
E_Migachev
14.12.2009 17:06Комментарий: 2
E_Migachev
Sokruto, хороший пример.
Sokruto
14.12.2009 13:44Комментарий: 1
Sokruto
предпочитаю так делать
Код 1C v 8.2 УП
 
Функция ФамилияИО(Сотрудник) Экспорт
Пока Найти(Сотрудник, " ") <> 0 Цикл
Сотрудник = СтрЗаменить(Сотрудник," "," ");
КонецЦикла;

Сотрудник = СтрЗаменить(Сотрудник," ",Символы.ПС);
Возврат СтрПолучитьСтроку(Сотрудник,1) + " "
+ Лев(СтрПолучитьСтроку(Сотрудник,2),1) + ". "
+Лев(СтрПолучитьСтроку(Сотрудник,3),1) + ".";
КонецФункции

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.