helpf.pro
Регистрация
 +4 
Распечатать

Открыть диалог выбора файла

Код 1C v 8.х
  //На форме есть поле (Путь к файлу), для кнопки Выбор (Событие начало выбора) пропишем процедуру выбора файла
Процедура ВыборФайла(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
СтандартнаяОбработка=ложь;
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Заголовок = "Выберите файл";
Диалог.ПолноеИмяФайла = "";
Фильтр = "EXE (*.exe)|*.exe";
Диалог.Фильтр = Фильтр;
Диалог.МножественныйВыбор = Ложь;
Диалог.Каталог = "F:\";
Если Диалог.Выбрать() Тогда
Элемент.значение = Диалог.ПолноеИмяФайла;
КонецЕсли;
КонецПроцедуры


Код 1C v 7.x
 ИмяВыбрФайла = "";
ИмяПути=КаталогИБ()+"ProgFile\";
Если ФС.ВыбратьФайл(0, ИмяВыбрФайла, ИмяПути, "Выберите файл запуска программы", "Все файлы (*.*)!*.*", , ) = 1 Тогда
ПутьЗ=СРЕД((ИмяПути + ИмяВыбрФайла),3,80);
КонецЕсли;
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 53713
 +4 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Посмотреть все результаты поиска похожих
Комментарии
Hangmaster
03.09.2013 15:39Комментарий: 6
Hangmaster
Премного благодарен!!!!! Сейчас проталкиваются везде УФ-ы и заказов стало край как много. Ваши наработки как нельзя более к стати!!!
E_Migachev
02.09.2013 23:02Комментарий: 5
E_Migachev
Hangmaster, для управляемого интерфейса используйте вот эти примеры
Hangmaster
02.09.2013 17:13Комментарий: 4
Hangmaster
В управляемом отчете форма
Элемент.Значение = Диалог.ПолноеИмяФайла;
выдало ошибку:
{Форма.Форма.Форма(14)}: Поле объекта не обнаружено (Значение)
Пришлось использовать конструкцию
Объект.ФайлВыгрузки
"ФайлВыгрузки" - полеВвода на форме отчета. В чем причина отказа работать - ХЗ. Движок 1С: 8.2.18.61.
luksiar
13.05.2012 12:57Комментарий: 3
luksiar
//На форме есть поле (Путь к файлу), для кнопки Выбор (Событие начало выбора) пропишем процедуру выбора файла

Подскажите пожалуста на какой форме?
DJ_Serega
06.03.2012 11:47Комментарий: 2
DJ_Serega
kuman123, в справке написано:
Код
ДиалогВыбораФайла (FileDialog)
Доступность:
Тонкий клиент, веб-клиент, толстый клиент.

Тоесть на сервере диалог не отрабатывает. Так как сервер это машина, и она сама не может выбрать папку ;)
kuman123
04.03.2012 19:07Комментарий: 1
kuman123
На 1с 8 Пишет ошибку
{Форма.Форма.Форма(9,17)}: Тип не определен (ДиалогВыбораФайла)
Диалог = Новый <<?>>ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); (Проверка: Сервер)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.