helpf.pro
Регистрация
 0 
Распечатать

Получение остатков регистра запросом, с группировкой по продукту и цене

Код 1C v 7.x
  ДатаК=РабочаяДата(); 
Запрос=СоздатьОбъект("Запрос");
ТекстЗапроса=
"//{{ЗАПРОС(ОстаткиТоваров)
|Период с '01.01.1990' по ДатаК;
|Продукт=Регистр.ПродОст.Продукция;
|Цена=Регистр.ПродОст.Цена;
|Колво=Регистр.ПродОст.Количество;
|Вес=Регистр.ПродОст.Вес;
|Функция КолвоНачОст=НачОст(КолВо);
|Функция КолвоПриход=Приход(КолВо);
|Функция КолвоРасход=Расход(КолВо);
|Функция КолвоКонОст=КонОст(КолВо);
|Функция ВесНачОст=НачОст(Вес);
|Функция ВесПриход=Приход(Вес);
|Функция ВесРасход=Расход(Вес);
|Функция ВесКонОст=КонОст(Вес);
|Группировка Продукт;
|Группировка Цена;
|"//}}ЗАПРОС
;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Сообщить("1");
//... код вывода
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("2");
//... код вывода
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("3");
//... код вывода
КонецЦикла;
КонецЦикла;
Сообщить("4");
//... код вывода
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5055
 0 
Распечатать
Возможно, вас также заинтересует
Внутреннее устройство PostgreSQL, в помощь администраторам 1С 0
Понимание архитектуры используемой СУБД очень важно для правильной эксплуатации, но местами переоценено: администратору, DevOps-специалисту или разработчику прикладных систем вовсе необязательно знать подробности...
Выгрузка картинок из базы 1С в XML 2
В нынешнее время для электронного каталога или интернет-магазина необходимо выгружать не только информацию о цене и характеристиках товара, но и сопутствующие изображения. Хранящиеся в базе или связанные с...
Скидки на товары 0
Какие видов скидок предусмотрены в прикладном решении Управление Торговлей? Конфигурация позволяет работать со следующими видами скидок: скидки по количеству товара, сумме документа, по виду оплаты, по дисконтной...
Типы номенклатуры «Набор-комплект» и «Набор-пакет» 0
Для чего предназначен тип номенклатуры «Набор-комплект»? Данный тип номенклатуры используется при оформлении продажи комплектов без предварительной сборки (например, комплект мебели, состоящий из дивана и двух...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.