helpf.pro
Регистрация
 0 
Распечатать

Реквизит ~ Cохранение значений реквизитов формы в файл

Код 1C v 8.х
 //Cохранение значений реквизитов формы в файл - таблицу значений тоже сохраняет.
Код следующий:
Процедура СохранитьЗначенияФормы()
СтруктураЭлементов = Новый Структура;
Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
Если ЗначениеЗаполнено(ЭлементФормы.Данные) Тогда
ЗнВСтр = ЗначениеВСтрокуВнутр(ЭлементФормы.Значение);
СтруктураЭлементов.Вставить(ЭлементФормы.Имя, ЗнВСтр);
КонецЕсли;
КонецЦикла;
ЗначениеВФайл("C:\temp\rekv.ini", СтруктураЭлементов);
КонецПроцедуры

Процедура ВосстановитьЗначенияФормы()
СтруктураЭлементов = Новый Структура;
СтруктураЭлементов = ЗначениеИзФайла("C:\temp\rekv.ini");
Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
Попытка
ЭлементФормы.Значение = ЗначениеИзСтрокиВнутр(СтруктураЭлементов[ЭлементФормы.Имя])
Исключение
КонецПопытки;
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9547
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.