helpf.pro
Регистрация
 0 
Распечатать

Загрузка данных из DBF файла в Таблицу Значений

Код 1C v 7.x
  Процедура ПоказатьДБФ(дбф, имяФайла) далее

Процедура Сформировать()
перем дбф, флаг, папка;
тЗнач.Очистить();
флаг=ФС.ВыбратьФайл(0, имяФайла, папка,"Выберете DBF файл","|*.DBF");
Если флаг=0 Тогда
возврат;
КонецЕсли;
дбф=СоздатьОбъект("Xbase");
дбф.ОткрытьФайл(папка+имяФайла);
папк=папка;
файл=имяФайла;
Если дбф.открыта()=0 Тогда
Предупреждение("Не могу открыть файл"+имяФайла);
возврат;
КонецЕсли;
ПоказатьДБФ(дбф, имяФайла);
КонецПроцедуры

Процедура ПоказатьДБФ(дбф, имяФайла)
Перем ин, имяПоля, тип, длина, точность, номСтроки;
для ин=1 по дбф.КоличествоПолей() цикл
дбф.ОписаниеПоля(ин, имяПоля, тип, длина, точность);
тЗнач.НоваяКолонка(имяПоля, тип);
тЗнач.УстановитьПараметрыКолонки(ин, тип, длина, точность,, мин(10, длина));
конецЦикла;

КолП=дбф.КоличествоПолей();
НомС=ДБФ.КоличествоЗаписей();

загТЗнач="Файл "+имяФайла;
дбф.Первая();
номСтроки=0;
Пока дбф.ВКонце()=0 Цикл
номСтроки=номСтроки+1;
тЗнач.НоваяСтрока(номСтроки);
для ин=1 по дбф.КоличествоПолей() цикл
тЗнач.УстановитьЗначение(номСтроки, ин, дбф.ПолучитьЗначениеПоля(ин));
КонецЦикла;
дбф.Следующая();
конецЦикла;
КонецПроцедуры
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 12057
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Комментарии
E_Migachev
25.12.2009 19:22Комментарий: 1
E_Migachev
Для загрузки DBF, XLS в 1С 8.1 рекомендую 1С-овскую обработку Загрузка Данных Из Табличного Документа Скачивать файлы может только зарегистрированный пользователь!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.