helpf.pro
Регистрация
 0 
Распечатать

Пример получения списка пользователей из файла users.usr

Получает из users.usr список пользователей, каталоги пользователей и даже хеши паролей
Код 1C v 7.x
 // заполним список пользователей 
FSO=createobject("Scripting.FileSystemObject");
WshShell = CreateObject("WScript.Shell");
Txt=FSO.OpenTextFile(КаталогИБ()+"usrdef\users.usr");
LineUser="";
ChI=0;
Пока Txt.AtEndOfStream=0 Цикл
Chi=Chi+1;
Buf=Txt.Read(1);
Если КодСимв(Buf)>31 Тогда
LineUser=LineUser+Buf;
КонецЕсли;
КонецЦикла;
LineBof="{"+chr(34)+"Container.Contents"+chr(34)+",";
LineUser=Сред(LineUser,Найти(LineUser,LineBof)+23);
LineUser=Сред(LineUser,1,Найти(LineUser,"}}"));
//Сп=СоздатьОбъект("СписокЗначений");
LineUser=СтрЗаменить(LineUser,РазделительСтрок," ");
LineUser=СтрЗаменить(LineUser,"},{",РазделительСтрок);
Для к=1 По СтрКоличествоСтрок(LineUser) Цикл
а=СтрЗаменить(СтрПолучитьСтроку(LineUser,к),Симв(34),"");
а=СтрЗаменить(СтрПолучитьСтроку(LineUser,к),"}","");
а=Сред(а,19);
а=Сред(а,Найти(а,",")+1);
а=Сред(а,1,Найти(а,",")-1);
а=СтрЗаменить(а,"""",""); // уберем кавычки
списПользователи.Установить(а,а);
КонецЦикла;
списПользователи.ТекущаяСтрока(1);
// Список Пользователей заполнен


Посмотрите еще:
Как получить список зарегистрированных пользователей базы 1С
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 10686
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
rphost занимает память и грузит процессор 12
У многих возникают проблемы с rphost.exe, разного вида: rphost занимает всю память rphost грузит процессор rphost жрет память причем 1С даже на запущена, а в диспетчере следующее: ежеминутно расчет на 2-3 мегабайта. Как быть и...
v7plus.dll - отсутствует CLSID либо отсутствует интерфейс llnitDone 0
При выгрузке отчетности в 1С 7.7 программа ругается на v7plus.dll и указывает, что отсутствует интерфейс llritDone. Что делать? 1) Поудалять нафиг все v7plus.dll из каталогов ИБ и папок пользователей 2) Оставить только в bin каталоге и...
V82.COMConnector.1: Не найдена лицензия COM-соединением 1
При подключении из одной базы к другой через COM внезапно стала появляться следующая ошибка: «V82.COMConnector.1: Не найдена лицензия COM-соединением», хотя никаких изменений на серверах не делалось. Релиз платформы был 8.2.13....
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.