helpf.pro
Регистрация
 0 
Распечатать

Как из ДереваЗначений сделать ТаблицуЗначений по определенному уровню

Код 1C v 8.х
 Функция СоздатьТЗПоДЗ(ДЗ,Ветка)
ТЗ = Новый ТаблицаЗначений;
Для Сч = 0 По ДЗ.Колонки.Количество()-1 Цикл
ТЗ.Колонки.Добавить(ДЗ.Колонки[Сч].Имя,ДЗ.Колонки[Сч].ТипЗначения,ДЗ.Колонки[Сч].Заголовок,ДЗ.Колонки[Сч].Ширина);
КонецЦикла;
Для Сч = 0 По Ветка.Количество()-1 Цикл
НоваяСтрока = ТЗ.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока,Ветка[Сч]);
КонецЦикла;
Возврат ТЗ;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8041
 0 
Распечатать
Возможно, вас также заинтересует
Группировка строк Excel 4
В ниже указанном коде нужно убрать символ _ //Группировка строк по уровню 2 Worksheet.Range(" 7:8" ).Rows.Group(); Worksheet.Range(" 10:11" ).Rows.Group(); Worksheet.Range(" 14:15" ).Rows.Group(); Worksheet.Range(" 17:18" ).Rows.Group(); /
Как получить ПредопределенноеЗначение? 0
Чтобы обратиться к предопределенному значению перечисления на клиенте нужно использовать метод глобального контекста ПредопределенноеЗначение (PredefinedValue) Синтаксис: ПредопределенноеЗначение(...
Механизмы обмена данными 0
Андрей Колесов Один из наиболее актуальных сегодня вопросов создания, поддержки и развития информационных систем организаций — задача интеграции их отдельных подсистем и компонентов. Платформа «1С:Предприятие 8»...
Настройка УТ для работы с Gmail 3
Скрестил Google Apps и почтовый клиент 1С УТ. Обработок и правки конфигурации не понадобиться, лишь одна сторонняя программа. Главная проблема в этом почтовом клиенте – отсутствие поддержки шифрования SSL для отправки и...
Ограничение доступа на уровне записей RLS 5
Когда требуется более тонкая настройка доступа, на помощь приходит механизм RLS - Record Level Security. Конфигурации системы «1С:Предприятие» 8 изначально позиционировалась как программа для многофирменного учета, и один из...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.