helpf.pro
Регистрация
 +2 
Распечатать

Как в дереве значений строку перекинуть в другой родитель?

Код 1C v 8.х
 Процедура ПереместитьСтрокуДерева(Дерево, ПеремещаемаяСтрока, НовыйРодитель, Уровень = 0)

Если Уровень = 0 Тогда

НоваяСтрока = НовыйРодитель.Строки.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока, ПеремещаемаяСтрока);
ПереместитьСтрокуДерева(Дерево, ПеремещаемаяСтрока, НоваяСтрока, Уровень + 1);

Если ПеремещаемаяСтрока.Родитель = Неопределено Тогда
Дерево.Строки.Удалить(ПеремещаемаяСтрока);
Иначе
ПеремещаемаяСтрока.Родитель.Строки.Удалить(ПеремещаемаяСтрока);
КонецЕсли;

Иначе

Для Каждого Стр ИЗ ПеремещаемаяСтрока.Строки Цикл
НоваяСтрока = НовыйРодитель.Строки.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока, ПеремещаемаяСтрока);
ПереместитьСтрокуДерева(Дерево, Стр, НоваяСтрока, Уровень + 1);
КонецЦикла;

КонецЕсли;

КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 21160
 +2 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 11
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который выпускает компания 1С . Что такое
Cклонения по падежам 5
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
Excel файл как Внешний источник данных 9
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . https://helpf.pro/uploads/img
V82.COMConnector.1: Не найдена лицензия COM-соединением 1
При подключении из одной базы к другой через COM внезапно стала появляться следующая ошибка: «V82.COMConnector.1: Не найдена лицензия COM-соединением», хотя никаких изменений на серверах не делалось. Релиз платформы был 8.2.13. Обновил до 14-го – не
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное ускорение видеокарты В Window
Посмотреть все результаты поиска похожих
Комментарии
McCoy
02.05.2012 10:28Комментарий: 1
McCoy
В цикле:
Код 1C v 8.х
 Для Каждого Стр ИЗ ПеремещаемаяСтрока.Строки Цикл

НоваяСтрока = НовыйРодитель.Строки.Добавить();

ЗаполнитьЗначенияСвойств(НоваяСтрока, ПеремещаемаяСтрока);

ПереместитьСтрокуДерева(Дерево, Стр, НоваяСтрока, Уровень + 1);

КонецЦикла;


допущена ошибка. Должно быть не:
Код 1C v 8.х
 ЗаполнитьЗначенияСвойств(НоваяСтрока, ПеремещаемаяСтрока);   

а
Код 1C v 8.х
 ЗаполнитьЗначенияСвойств(НоваяСтрока, Стр);   
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.