helpf.pro
Регистрация
 0 
Распечатать

Функция проверяет соответствие ОГРН Контрагента требованиям

ОГРН (основной государственный регистрационный номер) — государственный регистрационный номер записи о создании юридического лица либо записи о первом представлении в соответствии с Федеральным законом “О государственной регистрации юридических лиц” сведений о юридическом лице, зарегистрированном до введения в действие указанного Закона (пункт 8 Правил ведения Единого государственного реестра юридических лиц) (см. ОГРН в Википедии).

Структура ОГРН:

* 1 цифра – код, признак ОГРН (всегда равен 1);
* 2 цифры – две последние цифры года внесения записи в государственный реестр;
* 2 цифры – код региона по перечню регионов в 65-й статье Конституции
* 7 цифр – порядковый номер записи от начала года;
* 1 цифра – проверочный код ОГРН;

Что можно узнать зная ОГРН:

1. Год регистрации организации по двум последним цифрам.

2. С некоторой точностью месяц (а может быть и неделю) регистрации организации по порядковому номеру записи.

3. Код региона организации по 65-й статье Конституции.

4. По коду ОГРН может быть получена иная публичная информациия по организации – ИНН, КПП, наименование, адрес из публичного реестра ФНС.

Можно обратить внимание что ИНН и ОГРН отличаются принципами ведения порядковых номеров организаций. Если в ИНН они привязаны к налоговой инспекции, то в ОГРН к году регистрации. Соответственно исходя из возможности по порядковому номеру ИНН определить дату его присвоения, можно говорить что ИНН несёт чуть больше информации (номер инспекции) чем ОГРН.

Код 1C v 8.х
 // Параметры:
// ОГРН - строка - проверяемый основной государственный регистрационный номер
Функция ОГРНсоответствуетТребованиям(Знач ОГРН) Экспорт
Попытка
ОГРНБезВедущихНулей = Формат(ОГРН,"ЧГ=0");
Исключение
Возврат Ложь;
КонецПопытки;
ОГРН = Строка(ОГРНБезВедущихНулей);
Если СтрДлина(ОГРН) <> 13 Тогда
Возврат Ложь;
Иначе
Возврат Истина;//проверка временно отключена
КонецЕсли;
ОГРН12 = Число(Лев(ОГРН, 12));
Если Прав(Формат(ОГРН12%11, "ЧН=0; ЧГ=0"), 1) = Прав(ОГРН, 1) Тогда
Возврат Истина;
Иначе
Возврат Ложь;
КонецЕсли;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7866
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Посмотреть все результаты поиска похожих
Комментарии
Voittamaton
01.09.2011 07:40Комментарий: 1
Voittamaton
Из Википедии про структуру ОГРН:

Цитата
Государственный регистрационный номер записи, вносимой в Единый государственный реестр юридических лиц (далее — государственный реестр), состоит из 13 цифр, расположенных в следующей последовательности:
С Г Г К К Н Н Х Х Х Х Х Ч
где:
С (1-й знак) — признак отнесения государственного регистрационного номера записи:
к основному государственному регистрационному номеру (ОГРН)* — 1, 5
к иному государственному регистрационному номеру записи — 2
к основному государственному регистрационному номеру индивидуального предпринимателя (ОГРНИП)* — 3
ГГ (со 2-го по 3-й знак) — две последние цифры года внесения записи в государственный реестр
КК (4-й, 5-й знаки) — порядковый номер субъекта Российской Федерации по перечню субъектов Российской Федерации, установленному статьей 65 Конституции Российской Федерации
НН (6-й и 7-й знаки) — код номера межрайонной налоговой инспекции, выдавшей ОГРН юридическому лицу
ХХХХХ (с 8-го по 12-й знак) — номер записи, внесенной в государственный реестр в течение года
Ч (13-й знак) — контрольное число: остаток от деления предыдущего 12-значного числа на 11, если остаток от деления равен 10, то контрольное число равно 0 (нулю).
(Приложение № 1 к Правилам ведения Единого государственного реестра юридических лиц)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.