helpf.pro
Регистрация
 0 
Распечатать

Функции преобразуют табличный документ (ТД) в строку и обратно

Код 1C v 8.х
 Функция ТабличныйДокументВСтроку(ТД) Экспорт
Попытка
ИмяФайла=ПолучитьИмяВременногоФайла("MXL");
ТД.Записать(ИмяФайла);
ДД=Новый ДвоичныеДанные(ИмяФайла);
Стр=Base64Строка(ДД);
ДД=Неопределено;
УдалитьФайлы(ИмяФайла);
Возврат Стр;
Исключение
Возврат Неопределено;
КонецПопытки;
КонецФункции

Функция ТабличныйДокументИЗСтроки(ТД, Стр) Экспорт
Если СокрЛП(Стр)="" Тогда
Возврат ложь;
КонецЕсли;
Попытка
ДД=Base64Значение(Стр);
ИмяФайла=ПолучитьИмяВременногоФайла("MXL");
ДД.Записать(ИмяФайла);
ДД=Неопределено;
ТД.Прочитать(ИмяФайла);
УдалитьФайлы(ИмяФайла);
Возврат истина;
Исключение
Возврат ложь;
КонецПопытки;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6565
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.