helpf.pro
Регистрация
 0 
Распечатать

Функция выгружает справочник в таблицу значений

Пример выгрузки(помещения) справочника в Таблицу Значений (ТЗ):
Код 1C v 7.x
  // Параметры:
// ВидСправочника - Строка, указывающая вид справочника, как он задан в конфигураторе
// ДобавлятьЭлементыСправочника - 1- добавить колонку с наименованием "Элемент", содержащую элементы справочников, 0 - не добавлять колонку
// ИмяРеквизита - Имя реквизита, как он задан в конфигураторе. Используется при заполнении таблицы из выборки по значению реквизита.
// ЗначениеРеквизита - Значение реквизита, по которому надо построить выборку. Используется при заполнении таблицы из выборки по значению реквизита.
// ЭлементВладелец - Владелец, указывается для подчиненных справочников
// ЭлементРодитель - Родитель, используется в случае, если надо ограничить выборку условием принадлежности элементов одной группе
// ВключатьПодчиненные - Установить флаг выборки всех подчиненных элементов.
// Иерархия - Флаг указывающий на то как выбирать элементы (1 - выбирать элементы с учетом иерархии, 0 - выбирать элементы без учета иерархии)
// ВОбратномПорядке - Число: 1 - выбирать элементы справочника в обратном порядке; 0 - выбирать элементы справочника в прямом порядке
// ВключатьГруппы - 1 - выбирать среди групп справочника, 0 - выбирать только среди элементов
//
// Возвращает: Таблица значений, колонками которой, являются реквизиты справочника

Функция СправочникВТЗ(ВидСправочника, ДобавлятьЭлементыСправочника = 0,ИмяРеквизита = 0, ЗначениеРеквизита = 0, ЭлементВладелец = 0, ЭлементРодитель = 0, ВключатьПодчиненные = 1, Иерархия = 1, ВОбратномПорядке = 0, ВключатьГруппы = 0) Экспорт

ТаблицаСпр = СоздатьОбъект("ТаблицаЗначений");
мдСпр = Метаданные.Справочник(ВидСправочника);
ВсегоРеквизитовСпр = мдСпр.Реквизит();
Для индРекв = 1 по ВсегоРеквизитовСпр Цикл
Вид = мдСпр.Реквизит(индРекв).Вид;
ТаблицаСпр.НоваяКолонка(мдСпр.Реквизит(индРекв).Идентификатор, мдСпр.Реквизит(индРекв).Тип + ?(ПустоеЗначение(Вид) = 0, "." + Вид, ""), мдСпр.Реквизит(индРекв).Длина, мдСпр.Реквизит(индРекв).Точность);
КонецЦикла;
ТаблицаСпр.НоваяКолонка("Код", ?(мдСпр.ТипКода = "Текстовый", "Строка", "Число"), мдСпр.ДлинаКода);
ТаблицаСпр.НоваяКолонка("Наименование", "Строка", мдСпр.ДлинаНаименования);
Если ДобавлятьЭлементыСправочника = 1 тогда
ТаблицаСпр.НоваяКолонка("Элемент", "Справочник." + ВидСправочника);
КонецЕсли;
Спр = СоздатьОбъект("Справочник." + ВидСправочника);
Если ЭлементВладелец <> 0 тогда
Спр.ИспользоватьВладельца(ЭлементВладелец);
КонецЕсли;
Если ЭлементРодитель <> 0 тогда
Спр.ИспользоватьРодителя(ЭлементРодитель);
КонецЕсли;
Спр.ОбратныйПорядок(ВОбратномПорядке);
Спр.ВключатьПодчиненные(ВключатьПодчиненные);
Если ИмяРеквизита = 0 тогда
Спр.ВыбратьЭлементы(Иерархия);
Иначе
Спр.ВыбратьЭлементыПоРеквизиту(ИмяРеквизита, ЗначениеРеквизита, Иерархия, ВключатьГруппы);
КонецЕсли;

Пока Спр.ПолучитьЭлемент() = 1 Цикл

ТаблицаСпр.НоваяСтрока();
ТекущаяСтрока = ТаблицаСпр.НомерСтроки;
Для НомерКолонки= 1 по ВсегоРеквизитовСпр Цикл
ТаблицаСпр.УстановитьЗначение(ТекущаяСтрока, НомерКолонки, Спр.ПолучитьАтрибут(мдСпр.Реквизит(НомерКолонки)));
КонецЦикла;
ТаблицаСпр.Код = Спр.Код;
ТаблицаСпр.Наименование = Спр.Наименование;
Если ДобавлятьЭлементыСправочника = 1 тогда
ТаблицаСпр.УстановитьЗначение(ТекущаяСтрока, "Элемент", Спр.ТекущийЭлемент());
КонецЕсли;

КонецЦикла;

Возврат ТаблицаСпр;
КонецФункции
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 8422
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.