helpf.pro
Регистрация
 +2 
Распечатать

Как просмотреть структуру таблиц информационной базы?

В данном примере получается структура таблиц справочника Номенклатура (в общем случае с этим объектом может быть связано несколько таблиц):
Код 1C v 8.х
 МассивИменМетаданных = Новый Массив();
МассивИменМетаданных.Добавить("Справочник.Номенклатура");

// Таблица значений, содержащая таблицы указанного объекта.
Таблицы = ПолучитьСтруктуруХраненияБазыДанных(МассивИменМетаданных);

Для Каждого Таблица Из Таблицы Цикл

ПоляТаблицы = Таблица.Поля;

Для Каждого Поле Из ПоляТаблицы Цикл

// Просмотр свойств поля.

КонецЦикла;

ИндексыТаблицы = Таблица.Индексы;

Для Каждого Индекс Из ИндексыТаблицы Цикл

// Просмотр свойств индекса.

КонецЦикла;
КонецЦикла;

ПолучитьСтруктуруХраненияБазыДанных - возвращает таблицу значений с описаниями структуры таблиц, индексов и полей базы данных в терминах SDBL или используемой СУБД (MS SQL, PostgreSQL, IBM DB2)
Возможность получения структуры хранения базы данных может использоваться для выполнения административных действий. Информация о структуре хранения базы данных не должна применяться для реализации какой-либо части прикладной функциональности, а только для административных задач обслуживания базы данных и анализа записей технологического журнала.

Структура и название таблиц использыемых для хранения данных в БД 1С 8.х
Соответствие объектов 1С 8.х объектам в MS SQL
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 26263
 +2 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.