helpf.pro
Регистрация
 0 
Распечатать

Загрузка данных из таблицы Excel в ТЗ (Таблицу значений)

Код для 7 версии, при использовании в 8-ой - заменить E=СоздатьОбъект("Excel.Application");
на
E=Новый COMОбъект("Excel.Application");

Код 1C v 7.x
 Функция глОткрытьФайл(Маска="") Экспорт  
Перем ИмяФайла,ИмяКаталога;
Маска_="Файлы "+Маска+"|*."+Маска;
Если СокрЛП(Маска)="" Тогда
Маска_="Все файлы |*.*"
КонецЕсли;
Если ФС.ВыбратьФайл(0,ИмяФайла,ИмяКаталога,"Открыть файл",Маска_)=1 Тогда
Возврат ИмяКаталога+ИмяФайла; //полное имя открытого файла
Иначе
Возврат "";
КонецЕсли;
КонецФункции

Функция ReadExcel(ИмяФайла,Лист=1) Экспорт
Попытка
E=СоздатьОбъект("Excel.Application");
Исключение
Предупреждение("Excel на компьютере не установлен!");
Возврат ПолучитьПустоеЗначение();
КонецПопытки;
E.Workbooks.Open(Сокрлп(ИмяФайла));
Строк=E.Sheets(Лист).Cells.SpecialCells(11).Row; // строка последней ячейки
Столбцов=E.Sheets(Лист).Cells.SpecialCells(11).Column; // столбец последней ячейки
фТЗ=СоздатьОбъект("ТаблицаЗначений");
Для А=1 По Столбцов Цикл
фТЗ.НоваяКолонка();
КонецЦикла;
Для Стр=1 По Строк Цикл
Состояние("Обработано "+Строка(Стр)+" строк из "+Строка(Строк));
фТЗ.НоваяСтрока(Стр);
Для Столб=1 По Столбцов Цикл
фТЗ.УстановитьЗначение(Стр,Столб,СокрЛП(E.Sheets(Лист).Cells(Стр,Столб).Value));
КонецЦикла;
КонецЦикла;
E.Workbooks.Close();
Возврат фТЗ;
КонецФункции

Процедура Сформировать()
ИмяФайла=глОткрытьФайл("xls");
Если СокрЛП(ИмяФайла)="" Тогда Возврат; КонецЕсли;
ТЗ.Загрузить(ReadExcel(ИмяФайла,1)); // ТЗ - таблица значений на форме
// ну а дальше смотрим визуально, что с ней дальше делать
КонецПроцедуры

Подсказал Abadonna.
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 13747
 0 
Распечатать
Возможно, вас также заинтересует
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
COM-соединение не обнаружило свободной лицензии / ключ защиты 0
Иногда при подключении к 1С возникает ошибка: COM-соединение не обнаружило свободной лицензии! COM-соединение не обнаружило ключ защиты программы! https://helpf.pro/uploads/img/_1-UsuyAg6E2P.jpg В таких случаях, иногда, может помочь...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
V82.COMConnector.1: Не найдена лицензия COM-соединением 1
При подключении из одной базы к другой через COM внезапно стала появляться следующая ошибка: «V82.COMConnector.1: Не найдена лицензия COM-соединением», хотя никаких изменений на серверах не делалось. Релиз платформы был 8.2.13....
Активация открытой книги Excel для корректировки 0
Нужно было получить для изменения уже открытую книгу Excel, а если она закрыта, то открыть и изменять. Ниже код, который данную задачу решает. Попытка Эксель = Неопределено; Книга = Неопределено; Лист = Неопределено; ...
Посмотреть все результаты поиска похожих
Комментарии
Ermak
16.10.2012 17:03Комментарий: 1
Ermak
Было бы хорошо если бы кидали уже обработку, чтобы наглядно смотреть )
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.