helpf.pro
Регистрация
 0 
Распечатать

Функция проверяет наличие в строке только цифр

Код 1C v 8.х
 
// Функция проверяет наличие в строке только цифр
//
// Параметры
// СтрокаПроверки - Строка для проверки только цифр
//
// Возвращаемое значение:
// Булево
//
Функция ЕстьНеЦифры(Знач СтрокаПроверки) Экспорт

СписокКодовЧисел = Новый СписокЗначений;
Для а = 48 По 57 Цикл
СписокКодовЧисел.Добавить(а);
КонецЦикла;

СтрокаПроверки = СокрЛП(СтрокаПроверки);

Если ТипЗнч(СтрокаПроверки) <> Тип("Строка") Тогда

Возврат Истина;

Иначе

Для а = 1 По СтрДлина(СтрокаПроверки) Цикл
Если СписокКодовЧисел.НайтиПоЗначению(КодСимвола(Сред(СтрокаПроверки, а, 1))) = Неопределено Тогда
Возврат Истина;
КонецЕсли;
КонецЦикла;

КонецЕсли;

Возврат Ложь;

КонецФункции

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 5976
 0 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
rphost занимает память и грузит процессор 12
У многих возникают проблемы с rphost.exe, разного вида: rphost занимает всю память rphost грузит процессор rphost жрет память причем 1С даже на запущена, а в диспетчере следующее: ежеминутно расчет на 2-3 мегабайта. Как быть и...
Посмотреть все результаты поиска похожих
Комментарии
astonvilla
04.01.2013 18:29Комментарий: 3
astonvilla
да, и и в коде запятая в строке-эталоне лишняя (для меня это допустимый символ, т.к. я проверяю серия+запятая+номер в серии
astonvilla
04.01.2013 18:26Комментарий: 2
astonvilla
чет перекосило код )
Код 1C v 8.2 УП
 Функция ЕстьЗапрещенныеСимволы(СтрПроверки) Экспорт
СтрЭталон = "1234567890,";
Для Ном = 1 ПО СтрДлина(СтрПроверки) Цикл
Если Найти(СтрЭталон,Сред(СтрПроверки,Ном, 1)) = 0 Тогда
Возврат Истина;
КонецЕсли;
КонецЦикла;
Возврат Ложь;
КонецФункции
astonvilla
04.01.2013 18:25Комментарий: 1
astonvilla
Я использовал такой вариант

Код 1C v 8.2 УП
 Функция ЕстьНеЦифры(СтрПроверки) Экспорт
СтрЭталон = "1234567890,";
Для Ном = 1 ПО СтрДлина(СтрПроверки) Цикл
Если Найти(СтрЭталон,Сред(СтрПроверки,Ном, 1)) = 0 Тогда
Возврат Истина;
КонецЕсли;
КонецЦикла;
Возврат Ложь;
КонецФункции
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.