helpf.pro
Регистрация
 0 
Распечатать

Метод сортировки числового ряда пузырьком

Функция осуществляет сортировку числового ряда (в массиве) от малого к большему http://ru.wikipedia.org/wiki/Сортировка_пузырьком методом "пузырька"[/url] Область применения достаточно широка.

Код 1C v 8.х
 
Функция СортировкаПузырьком(МассивЭлементов) Экспорт
// Количество просмотров массива - по количеству числа его элементов
Для просмотр = 0 По МассивЭлементов.Количество()-1 Цикл
// Собственно, просмотр массива
Для индекс = 0 По МассивЭлементов.Количество()-1 Цикл
// Если достигли конца массива то прервём цикл,
// чтобы не выполнять условие ниже
Если индекс = МассивЭлементов.Количество()-1 Тогда
Прервать;
КонецЕсли;
// Сравнение элементов и их перестановка (если требуется)
Если МассивЭлементов[индекс] > МассивЭлементов[индекс+1] Тогда
СтаршийЭлемент = МассивЭлементов[индекс];
МладшийЭлемент = МассивЭлементов[индекс+1];
МассивЭлементов[индекс] = МладшийЭлемент;
МассивЭлементов[индекс+1] = СтаршийЭлемент;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Возврат МассивЭлементов;
КонецФункции

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8689
 0 
Распечатать
Возможно, вас также заинтересует
Ввод договоров ГПХ в ЗУП (счет 76) 5
Часто меня спрашивают: Как правильно отразить договор ГПХ в ЗУП? Ниже небольшая, последовательная инструкция: Прием на работу Сведения о физическом лице, выполняющем работы по договору подряда, должны быть внесены...
Выгрузка данных в Excel с установкой разных параметров 4
// Процедура выгружает из указанного справочника данные в режиме экспорта в файл в формате Microsoft Excel // с указанным именем, используя преобразование данных к типу число и типу строка; Процедура...
Группировка строк Excel 4
В ниже указанном коде нужно убрать символ _ //Группировка строк по уровню 2 Worksheet.Range(" 7:8" ).Rows.Group(); Worksheet.Range(" 10:11" ).Rows.Group(); Worksheet.Range(" 14:15" ).Rows.Group(); Worksheet.Range(" 17:18" ).Rows.Group(); /
Данные Графика регистра расчета 0
Виртуальная таблица " РегистрРасчета. ИмяРегистра .ДанныеГрафика " определена для тех регистров расчета, которые поддерживают период действия . При конфигурировании с таким регистром расчета необходимо связать...
Использование ASCII кодов в 1С 2
Хотите писать в 1С не только стандартными буквами, знаками изображенными на клавиатуре и вставлять опять же стандартные смайлики, а тем не менее существует возможность ставить дополнительные символы, так же можно...
Посмотреть все результаты поиска похожих
Комментарии
IKSparrow
06.04.2010 10:15Комментарий: 2
IKSparrow
Сейчас с ЗИКом разгребусь окончательно и понакидаю примерчиков по сортировке, подбору. В торговых системах такое может пригодиться. А там, глядишь и до КД доберусь *06
E_Migachev
06.04.2010 10:10Комментарий: 1
E_Migachev
) хороший пример сортировки, Спасибо!
Только вот ссылки с кириллицей не отображаются *11, исправлю...
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.