helpf.pro
Регистрация
 0 
Распечатать

Как получить список реквизитов операции и проводок?

Код 1C v 7.x
  // Пример 1
Для к = 1 по Метаданные.РеквизитПроводки()
Сообщить(Метаданные.РеквизитПроводки(к).Идентификатор);
КонецЦикла;


Код 1C v 7.x
  // Пример 2
СписокРеквизитов = СоздатьОбъект("СписокЗначений");
// реквизиты формы операции
СписокРеквизитов.ДобавитьЗначение("ДатаОперации");
СписокРеквизитов.ДобавитьЗначение("НомерДок");
СписокРеквизитов.ДобавитьЗначение("СуммаОперации");
СписокРеквизитов.ДобавитьЗначение("Содержание");

// Дополнительные реквизиты операции
Для М1 = 1 По Метаданные.РеквизитОперации() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.РеквизитОперации(М1).Идентификатор);
КонецЦикла;

// Общие реквизиты документов
Для М1 = 1 По Метаданные.ОбщийРеквизитДокумента() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.ОбщийРеквизитДокумента(М1).Идентификатор);
КонецЦикла;

СписокРеквизитов.ДобавитьЗначение("НомерПроводки");
СписокРеквизитов.ДобавитьЗначение("ПланСчетов");
СписокРеквизитов.ДобавитьЗначение("СчетДт");
СписокРеквизитов.ДобавитьЗначение("СчетКт");
СписокРеквизитов.ДобавитьЗначение("Субконто");
СписокРеквизитов.ДобавитьЗначение("СубконтоДт");
СписокРеквизитов.ДобавитьЗначение("СубконтоКт");

Для М1 = 1 По Метаданные.МаксимальноеКоличествоСубконто Цикл
СписокРеквизитов.ДобавитьЗначение("Субконто" + М1);
СписокРеквизитов.ДобавитьЗначение("СубконтоКт" + М1);
СписокРеквизитов.ДобавитьЗначение("СубконтоДт" + М1);
КонецЦикла;


СписокРеквизитов.ДобавитьЗначение("Валюта");
СписокРеквизитов.ДобавитьЗначение("Курс");
СписокРеквизитов.ДобавитьЗначение("Количество");
СписокРеквизитов.ДобавитьЗначение("ВалСумма");
СписокРеквизитов.ДобавитьЗначение("Сумма");
СписокРеквизитов.ДобавитьЗначение("НомерСтроки");

// Дополнительные реквизиты проводки
Для М1 = 1 По Метаданные.РеквизитПроводки() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.РеквизитПроводки(М1).Идентификатор);
КонецЦикла;

// журнал операций
СписокРеквизитов.ДобавитьЗначение("ВидДок");
СписокРеквизитов.ДобавитьЗначение("ВремяОперации");

// Дополнительные графы журнала операций
Для М1 = 1 По Метаданные.ГрафаЖурналаОпераций() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.ГрафаЖурналаОпераций(М1).Идентификатор);
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5559
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Microsoft SQL Server Native Client Добавление значения в столбец "datetime" привело к переполнению 0
При формировании отчета на СКД получили ошибку: Microsoft SQL Server Native Client 11.0: Добавление значения в столбец "datetime" привело к переполнению Подробнее текст такой: ... по причине: Ошибка компоновки данных по причине: Ошибка...
rphost занимает память и грузит процессор 12
У многих возникают проблемы с rphost.exe, разного вида: rphost занимает всю память rphost грузит процессор rphost жрет память причем 1С даже на запущена, а в диспетчере следующее: ежеминутно расчет на 2-3 мегабайта. Как быть и...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Выгрузка и Загрузка проводок документа через файл 0
Процедура ВыгрузкаПроводок(Кнопка) Если Не ЗначениеЗаполнено(Документ) Тогда Сообщить(" Заполните поле Документ!" ); Иначе Движ = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей(); ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.