helpf.pro
Регистрация
 0 
Распечатать

Выгрузка и Загрузка проводок документа через файл

Код 1C v 8.х
 Процедура ВыгрузкаПроводок(Кнопка)
Если Не ЗначениеЗаполнено(Документ) Тогда
Сообщить("Заполните поле Документ!");
Иначе
Движ = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
Движ.Отбор.Регистратор.Установить(Документ);
Движ.Прочитать();
ТЗ = Движ.Выгрузить();
ПараметрОтбора = Новый Структура("СчетДт",Счет);
ТЗИтог = ТЗ.Скопировать(ПараметрОтбора);
Если ЗначениеВФайл("D:\OUT.TXT",ТЗ) Тогда
Сообщить("Создан файл ""D:\OUT.TXT""");
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Процедура ЗагрузитьПроводки(Кнопка)
ТЗЗагрузка = ЗначениеИзФайла("D:\OUT.TXT");
Движ = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
Движ.Отбор.Регистратор.Установить(Документ);
Движ.Прочитать();
ТЗ = Движ.Выгрузить();
Для Каждого Эл Из ТЗЗагрузка Цикл
ПараметрОтбора = Новый Структура("СчетДт,СубконтоДт1",Эл.СчетДт,Эл.СубконтоДт1);
Массив = ТЗ.НайтиСтроки(ПараметрОтбора);
Если Массив.Количество()>0 Тогда
Сообщить("Запись есть - Пропускаем!");
Продолжить;
Иначе
Сообщить("Записи нет - Добавляем!");
НоваяСтрока = ТЗ.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока,Эл);
КонецЕсли;
КонецЦикла;
Движ.Загрузить(ТЗ);
Движ.Записать();
Сообщить("Проводки для данного документа созданы успешно!");
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8020
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.