helpf.pro
Регистрация
 0 
Распечатать

Получить имя принтера выбранного по умолчанию

Код 1C v 7.x
  // maharbA
Функция Hex(Пар)
Результат="";
Пока Пар>0 Цикл
Результат=Сред("0123456789ABCDEF",Пар+1,1)+Результат;
Пар=Цел(Пар/16) ;
КонецЦикла;
Возврат ""+Результат;
КонецФункции
Функция ПолучитьПринтерПоУмолчанию()
ПринтерПоУмолчанию="";
Scr = CreateObject("MSScriptControl.ScriptControl");
Scr.Language = "javascript";
Scr.Timeout=-1;
КоллекцияПринтеров = Service.ExecQuery("S_elect Name,Attributes from Win32_Printer");
Scr.AddObject("o",КоллекцияПринтеров);
e=Scr.eval("new Enumerator(o);");
Пока e.atEnd(0)=0 Цикл
БайтАтрибута=Прав(Hex(e.item(0).Attributes),1);
Если ((БайтАтрибута>"3") И (БайтАтрибута<"8")) или (БайтАтрибута>"B") Тогда
ПринтерПоУмолчанию=e.item(0).Name;
Прервать;
КонецЕсли;
e.moveNext(0);
КонецЦикла;
Возврат ПринтерПоУмолчанию;
КонецФункции
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6604
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 3
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C медленно работает по сети с базой на SQL Server 9
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1C: Enterprise Development Tools 37
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.