helpf.pro
Регистрация
 0 
Распечатать

Как получить вид объекта по переданной ссылке?

Код 1C v 8.х
 
// Возвращает вид объекта по переданной ссылке - строку "Справочник", "Документ" и т.д.
// Не обрабатываются точки маршрутов бизнес-процессов.
Функция ВидОбъектаПоСсылке(Ссылка) Экспорт
ТипСсылки = ТипЗнч(Ссылка);
Если Справочники.ТипВсеСсылки().СодержитТип(ТипСсылки) Тогда
Возврат "Справочник";

ИначеЕсли Документы.ТипВсеСсылки().СодержитТип(ТипСсылки) Тогда
Возврат "Документ";

ИначеЕсли БизнесПроцессы.ТипВсеСсылки().СодержитТип(ТипСсылки) Тогда
Возврат "БизнесПроцесс";

ИначеЕсли ПланыВидовХарактеристик.ТипВсеСсылки().СодержитТип(ТипСсылки) Тогда
Возврат "ПланВидовХарактеристик";

ИначеЕсли ПланыСчетов.ТипВсеСсылки().СодержитТип(ТипСсылки) Тогда
Возврат "ПланСчетов";

ИначеЕсли ПланыВидовРасчета.ТипВсеСсылки().СодержитТип(ТипСсылки) Тогда
Возврат "ПланВидовРасчета";

ИначеЕсли Задачи.ТипВсеСсылки().СодержитТип(ТипСсылки) Тогда
Возврат "Задача";

ИначеЕсли ПланыОбмена.ТипВсеСсылки().СодержитТип(ТипСсылки) Тогда
Возврат "ПланОбмена";

ИначеЕсли Перечисления.ТипВсеСсылки().СодержитТип(ТипСсылки) Тогда
Возврат "Перечисление";

Иначе
Возврат "";

КонецЕсли;

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6831
 0 
Распечатать
Возможно, вас также заинтересует
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное...
Временные таблицы в отчетах СКД 0
Нужно в отчете СКД Связать Данные из Регистра Накопления ВзаиморасчетыСРаботниками и Табличной Части Документа ЗарплатаКВыплате по Ссылке на Документ и ФизЛицу! И вывести полученные данные за указанный Период(с...
Временные таблицы, что из себя представляют и как с ними работать? 5
Временные таблицы - хранятся на сервере и позволяют писать более простые запросы. Временные таблицы хранятся в объекте типа МенеджерВременныхТаблиц . Когда этот объект уничтожается, уничтожаются и временные...
Вывод (печать) таблицы значений в табличный документ 4
Пример кода быстрая Печать таблицы значений //ТПОтчета - Табличное поле с формы (Таблица значений) с данными ПострПечать = Новый ПостроительОтчета; ПострПечать.ИсточникДанных = Новый...
Выгрузка форматированного документа 1С на свой сайт 0
Пользователи в 1с ведут описание объектов, которые редактируются в объекте ФорматированныйДокумент. Необходимо обеспечить выгрузку форматированного документа на фтп. Для решения этой задачи воспользуемся методом...
Посмотреть все результаты поиска похожих
Комментарии
Altair
09.01.2013 17:45Комментарий: 1
Altair
Код 1C v 8.х
 Функция ТипЗначенияСтр(Ссылка) Экспорт
Попытка
МД = Метаданные.НайтиПоТипу(ТипЗнч(Ссылка)).ПолноеИмя();
Возврат Лев(МД, Найти(МД, ".") - 1);
Исключение
Возврат "";
КонецПопытки;
КонецФункции // ТипЗначенияСтр(Ссылка)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.