helpf.pro
Регистрация
 0 
Распечатать

Проверка правописания и орфографии

Код 1C v 8.х
 ТекстДляПроверки = "Данный текст садержит как минемум три ошипки !";

Процедура КнопкаВыполнитьНажатие(Кнопка)
// Создадим объект MS Word, он должен быть установлен
Попытка
Word = Новый COMОбъект("Word.Application");
Исключение
Предупреждение("Microsoft Word не установлен!",,"Ошибка!");
Возврат;
КонецПопытки;

НетОшибок = Word.CheckSpelling(ТекстДляПроверки);
Если НетОшибок Тогда // Все правильно
Сообщить("Нет ошибок");
Иначе // текст содержит ошибки. Проверим каждое слово и выведем ошибочные.
Док = Word.Documents.Add(); // Создадим новый документ
Область = Док.Range(0,0); // Получим пустую область в начале документа
Область.I_nsertBefore(ТекстДляПроверки); // Добавим в документ текст
Для каждого Слово Из Область.Words Цикл
СловоДляПроверки = СокрЛП(Слово.Text);
НетОшибок = Word.CheckSpelling(СловоДляПроверки);
Если НЕ НетОшибок Тогда // Слово ошибочно
// покажем возможные замены неправильного слова
СтрокаВариантов = "";
// Получим варианты правописания
Варианты = Слово.GetSpellingSuggestions( ,1, ,0);
Для каждого Вариант Из Варианты Цикл
СтрокаВариантов = СтрокаВариантов + ", " + Вариант.Name;
КонецЦикла;
СтрокаВариантов = ". Варианты замены: " + Сред(СтрокаВариантов, 2);
Сообщить("Ошибка в слове: " + СловоДляПроверки + СтрокаВариантов);
КонецЕсли;
КонецЦикла;
КонецЕсли;
Док.Close(0,,); // закроем документ без сохранения wdDoNotSaveChanges
Word.Quit(); // закроем Word
КонецПроцедуры


Еще посмотрите ActiveX-компоненту, которая проверяет правописание текста.
Основана на технологии OpenOffice MySpell. Не требует установленного офиса.
В комплекте словари для 10 языков, включая русский (с "ё"). Автор: dushelov
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8384
 0 
Распечатать
Возможно, вас также заинтересует
Механизмы обмена данными 0
Андрей Колесов Один из наиболее актуальных сегодня вопросов создания, поддержки и развития информационных систем организаций — задача интеграции их отдельных подсистем и компонентов. Платформа «1С:Предприятие 8»...
Практическая работа с почтой (E-mail,The Bat, Outlook, Mozilla Thunderbird) 0
Попытка ОтправитьПоПочте2(ТекСтрока); // работает с Батом Исключение Попытка ОтправитьПоПочте1(ТекСтрока); // работает с Аутлуком, но переспрашивает при отправке Исключение Сообщить_и_записать(" Ошибка при отправке...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.