helpf.pro
Регистрация
 +1 
Распечатать

Как выбрать записи из регистра сведений?

Код 1C v 8.х
  //ВНИМАНИЕ !!! 
// В качестве полей для отбора могут задаваться измерения или реквизиты, для которых
// в конфигураторе признак индексирования установлен в значение "Индексировать" или
// установлен признак "Ведущее". Вид сравнения может быть только Равно.

// Пример 1 Периодический регистр сведений
Отбор = Новый Структура("Сотрудник");
Отбор.Сотрудник = Результат.Сотрудник;
ВыборкаОКЛАД = РегистрыСведений.ПлановыеНачисленияРаботниковОрганизаций.Выбрать(Результат.Период,ТекДата, Отбор);

// КРАТКИЙ ВАРИАНТ
ВыборкаОКЛАД = РегистрыСведений.ПлановыеНачисленияРаботниковОрганизаций.Выбрать(Результат.Период,ТекДата,Новый Структура("Сотрудник", Результат.Сотрудник));
СумОкл=0;
Пока ВыборкаОКЛАД.Следующий() Цикл
СумОкл=СумОкл+ВыборкаОКЛАД.Показатель1;
КонецЦикла;

// Пример 2 Непериодический регистр сведений
ВыборкаОРГ = РегистрыСведений.КонтактнаяИнформация.Выбрать(Новый Структура("Объект", Организация));
Пока ВыборкаОРГ.Следующий() Цикл
Если Строка(ВыборкаОРГ.Вид) = "Юридический адрес организации" Тогда
ЮрАдрес = ВыборкаОРГ.Представление;
ИначеЕсли Строка(ВыборкаОРГ.Вид) = "Телефон организации" Тогда
Телефон = ВыборкаОРГ.Представление;
КонецЕсли;
КонецЦикла;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 41810
 +1 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Блокировка записей, невозможно изменить или удалить из регистра. Конфликт блокировок MS SQL + 1C 1
При попытке удалить запись из регистра сведений - получаю ошибку: она заблокирована, ошибка блокировок и т.д. Отключил всех пользователей, перезапустил сервер, пробую удалить - опять ошибка блокировки :( Путем тестов...
В учетной политике не указан вид тарифа страховых взносов. Как указать? 0
Создайте новую запись учетной политики с начала года - Например 01.01.2013 В учетной смотрите дату начала учетной политики. Поставьте дату начала года (например 01.01.13) закладка появиться должна. Проверьте Тариф страховых...
Посмотреть все результаты поиска похожих
Комментарии
Sekator
25.06.2013 15:13Комментарий: 2
Sekator
Запросом вроде быстрее )
Alexey_A
24.11.2012 17:04Комментарий: 1
Alexey_A
Спасибо! очень полезная инфа!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.