helpf.pro
Регистрация
 +2 
Распечатать

Как отключить узел от распределенной информационной базы?

1. Создаешь внешнюю обработку или отчет в ней форме пишешь
Код 1C v 8.х
 "ПланыОбмена.УстановитьГлавныйУзел(Неопределено);"   

2. Сохраняешь обработку.
3. Закрываешь конфигуратор
4. Запускаешь пользовательский режим.
5. Запускаешь обработку.


Еще Вариант кода:
Код 1C v 8.х
 Процедура ОтключитьГлавныйУзелНажатие(Элемент)
Если ПланыОбмена.ГлавныйУзел()<> Неопределено Тогда
СохранитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном", ПланыОбмена.ГлавныйУзел());
ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
КонецЕсли;
Предупреждение("Главный узел отключен");
КонецПроцедуры

Процедура ВосстановитьГлавныйУзелНажатие(Элемент)
Если ПланыОбмена.ГлавныйУзел()= Неопределено Тогда
ПланыОбмена.УстановитьГлавныйУзел(ВосстановитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном"));
КонецЕсли;
Предупреждение("Главный узел восстановлен");
КонецПроцедуры


Готовая обработка Отключить Восстановить Подчиненный Узел От Главный Узел Скачивать файлы может только зарегистрированный пользователь!
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 20276
 +2 
Распечатать
Возможно, вас также заинтересует
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
HTML5 Canvas в 1С 8.3 или Google нам поможет 0
Добрался я для написания маленьких тестов для 1С в плане web графики. Версии 1С 8.2.61 и 8.3.3.641. Зайдем на http://www.w3schools.com/html/html5_canvas.asp и перенесем примеры в обработку 1С. Скачать обработку: Результаты не радуют. 1С в Intern
Авто добавление обработки в справочник Внешних обработок 0
Чтобы не изменять типовую конфигурацию приходится использовать типовой механизм внешних печатных форм и обработок. Данный код проверяет - добавлена ли открываемая обработка в конфигурацию, если нет - задает вопрос и...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
Посмотреть все результаты поиска похожих
Комментарии
artemdinho
17.07.2013 13:04Комментарий: 6
artemdinho
Большое спасибо. Второй вариант кода очень помог.
ybyfc
04.04.2012 03:44Комментарий: 5
ybyfc
Спасибо за обработку. Спасли переферию.
S_Magdich
21.07.2011 12:03Комментарий: 4
S_Magdich
Кстати забыл сказать привинтил обратно базу к главной при помощи вышеописанной обработки. Спасибо E_Migachev
S_Magdich
21.07.2011 11:59Комментарий: 3
S_Magdich
Доброе время суток. Хочу поделиться с вами своим горьким опытом по обмену между узлами.

Дело было так:
Была база(Как потом выяснилось - главная), в базе была ошибка, вылетала при переходе на новый релиз (где-то в зарплате, какая - то дата не определялась), правдами и не правдами - я её додумался как обойти(в конфигураторе - все же программист 1с), потом таки обновил. Через некоторое время - мне звонят и говорят "Наша подчиненная база не запускается вообще. Разберись с этим".
Захожу к ним по удаленке, смотрю - точно не запускается, та же ошибка что и в главной базе.

Итого:
1.есть главный узел - с новым релизом и новыми документами;
2.есть подчиненный узел - тоже с новыми документами и старым релизом.

Подчиненная запускается и сразу просит обновиться(Окно обновлений открывается модально - никуда не залезешь, Ctr + O - тоже не работает.)

Цель: отвентить подчиненную базу, поправить код в подчиненной базе, перейти не новый релиз, поправит код обратно, привинтить обратно к главной базе.

Решение: Как оказалось все на много проще чем я думал. Есть такая полезная штука ка "Запуск 1с из командной строки". К стати если кто знает где есть более полная инфа по запуску 1с из командной строки - поделитесь пож., а то в инете только некоторые параметры.

Итак лечение подчиненной базы -
Запустить конфигуратор с параметром командной строки /ResetMasterNode (для базовых версий не используется).

Надеюсь еще кому-нибудь эта инфа поможет.
E_Migachev
31.08.2010 20:40Комментарий: 2
E_Migachev
Все зависит от того - насколько важные данные ты собираешься поменять и передадутся ли эти данные к ним в центральную базу! В принципе ничего страшного, если ты реально осознаешь что делаешь! )
Monfiz
31.08.2010 18:03Комментарий: 1
Monfiz
Скажите, если я отключу главный узел, затем изменю пару документов и потом восстановлю его, то база может запороться? Я хочу убедиться что за такие методы люди сверху по шапке не настучат...
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.