helpf.pro
Регистрация
 0 
Распечатать

Перемещение между документами в списке

Код 1C v 8.х
 //black_doctor, надеюсь комунить пригодиться механизм )))
//
//В примере описан механизм перехода между документами одного типа
//функции помещаються в общие , ну и от туда работают, для любого документа )
//в качестве входящих параметров задаем ссылку на документ и ссылку на текущую форму )

Процедура СледующийНажатие(док,ТекФорма) Экспорт
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ Первые 1
| ОперацииЦБ.Ссылка КАК Ссылка
|ИЗ
| ";
Запрос.Текст = Запрос.Текст+"Документ."+Док.ссылка.Метаданные().Имя+"
КАК ОперацииЦБ
|ГДЕ
| ОперацииЦБ.МоментВремени > &МоментВремени
|
|УПОРЯДОЧИТЬ ПО
| ОперацииЦБ.МоментВремени";
Запрос.УстановитьПараметр("МоментВремени",док.МоментВремени());
Результат = Запрос.Выполнить().Выгрузить();
Если Результат.Количество()>0 тогда
Формочка = Результат[0].Ссылка.ПолучитьОбъект().ПолучитьФорму();
Формочка.ПоложениеОкна = ТекФорма.ПоложениеОкна;
ТекФорма.Закрыть();
Формочка.Открыть();
Иначе Сообщить("Этот документ первый в списке документов",СтатусСообщения.Внимание);
КонецЕсли;
КонецПроцедуры

Процедура ПредыдущийНажатие(док,ТекФорма) Экспорт
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ Первые 1
| ОперацииЦБ.Ссылка КАК Ссылка
|ИЗ
| ";
Запрос.Текст = Запрос.Текст+"Документ."+Док.ссылка.Метаданные().Имя+"
КАК ОперацииЦБ
|ГДЕ
| ОперацииЦБ.МоментВремени < &МоментВремени
|
|УПОРЯДОЧИТЬ ПО
| ОперацииЦБ.МоментВремени УБЫВ";
Запрос.УстановитьПараметр("МоментВремени",док.МоментВремени());
Результат = Запрос.Выполнить().Выгрузить();
Если Результат.Количество()>0 тогда
Формочка = Результат[0].Ссылка.ПолучитьОбъект().ПолучитьФорму();
Формочка.ПоложениеОкна = ТекФорма.ПоложениеОкна;
ТекФорма.Закрыть();
Формочка.Открыть();
Иначе Сообщить("Этот документ первый в списке документов",СтатусСообщения.Внимание);
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 6540
 0 
Распечатать
Возможно, вас также заинтересует
Автоматическая архивация баз 1С с использованием Cobian Backup и VBS скриптов 6
Клиент попросил настроить автоматическую архивацию баз 1С раз в три дня и выгрузку архивов на Dropbox и на FTP Сервер. Кроме 1С нужно архивировать папку с рабочими документами. Хочет - так хочет, делаем: Первым делом...
Быстрый отбор в справочнике по первой букве 0
В статье описан способ быстрой организации отбора в списке справочника по первой букве наименования. Механизм легко дотачивается под собственные нужды. https://helpf.pro/uploads/img/_1-T4ZDj6uNPX.png // ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ ...
В регламентированной отчетности не печается штрих-код 1С ( EanGnivc ) 0
Установка шрифта EanGnivc В формах регламентированной отчетности, например, налоговые декларации, которые введены для предоставления отчетности, на всех листах в левом верхнем углу содержат свой уникальный штрих-код. В...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Посмотреть все результаты поиска похожих
Комментарии
E_Migachev
03.09.2010 15:55Комментарий: 2
E_Migachev
Mokey, Ты привел пример простого перемещения по списку документов! А Автор предложил сделать на форме списка или самого документа кнопки << >> (влево вправо) при нажати на которые будет открываться форма предыдущего или следующего документа! вот как-то так... )
Mokey
03.09.2010 15:49Комментарий: 1
Mokey
А штатными средствами перемещаться невозможно? Например, в форме списка клавиши "UP" и "Down". ))
Или просто автор не до конца раскрыл тему "Зачем, почему и когда" это может комунить пригодиться.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.