helpf.pro
Регистрация
 0 
Распечатать

Универсальное использование HTML Редактора

Гуляя по просторам интернета, случайно наткнулся на обработку HTML Редактор (Андрей Михайлов aka MAV):

title

Далее, пришла в голову интересная идея, сделать красивыми комментарии в документах ( у нас они очень большие и многострочные, в отдельной закладке), с поддержкой копирования информации из WORD и EXCEL, с сохранением всех цветов и стилей. Подредактировав данную обработку, стали доступны следующие функции:

1. Добавление текста

2. Добавление, просмотр и печать

3. Просмотр и печать

Теперь, более подробно:

Вот так выгляди поле комментариев в нашей базе:
title

1. Нажав на кнопку "Добавить комментарий" срабатывает Процедура ДобавитьКоммент(Элемент)
Код 1C v 8.х
 
Процедура ДобавитьКоммент(Элемент)
форм=обработки.HTML.ПолучитьФорму("Форма");
текст = форм.ОткрытьМодально();
если не Пустаястрока(текст) тогда
комментарий="Добавил: "+глтекущийпользователь+" , Добавлено: "+текущаядата()+текст+комментарий;
ЭлементыФормы.ПолеHTMLДокумента.УстановитьТекст(комментарий);
конецесли;
КонецПроцедуры

2. Процедура вызова "Добавление, просмотр и печать"
Код 1C v 8.х
 
Процедура ВставитьПланГрафик(Кнопка)
форм=обработки.HTML.ПолучитьФорму("ФормаПросмотра");
форм.текст=ПланГрафик;
текст=форм.ОткрытьМодально();
ПланГрафик=текст+ПланГрафик;
КонецПроцедуры

Откроется форма, вида:
title

Нажав на "Добавить запись" и вставив Таблицу из Excel:
title

Нажимаем Добавить и получаем:
title

3. Просмотр и печать
Код 1C v 8.х
 
Процедура ИсторияИзмененийПросмотр(Кнопка)
форм=обработки.HTML.ПолучитьФорму("Просмотр");
форм.текст=ИсторияИзменений;
форм.ОткрытьМодально();
КонецПроцедуры

Откроется форма просмотра реквизита ИсторияИзменений.

Обработка HTML редактор:
Для 8.0
Для 8.1
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 17923
 0 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 47
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Google maps : вывод точек на карту и режим панорамы 4
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С возможностью просмотра панора
PostgreSQL: установка, настройка, обслуживание 9
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут накладываться на всю таблиц
QR код в 1С 19
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После тог
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ объектов, обработок, подключаемых к отч
Посмотреть все результаты поиска похожих
Комментарии
mctsimco
24.05.2013 19:02Комментарий: 4
mctsimco
И небольшой баг...
В конце процедуры
Код 1C v 8.2 УП
 ПриОткрытии()    

неплохо бы добавить строку:
Код 1C v 8.2 УП
 Документ.Write(Текст);   
mctsimco
24.05.2013 18:18Комментарий: 3
mctsimco
Это офигенно !
Прикрутил за 30 секунд, полет нормальный.
E_Migachev
28.06.2011 17:41Комментарий: 2
E_Migachev
Kola, добавляешь эту обработку в обработки конфигурации и для редактирования полного описания пишешь:
Код 1C v 8.х
 форм=обработки.HTML.ПолучитьФорму("Просмотр");
форм.текст=Номенклатура.ПолноеОписание;
ИзменТекст = форм.ОткрытьМодально();
Номенклатура.ПолноеОписание= ИзменТекст;

далее записываешь номенклатуру
Kola
28.06.2011 17:23Комментарий: 1
Kola
Было бы замечательно, если бы автор или кто-то еще подсказал неодинеснику, как эту штуку интегрировать в форму редактирования элемента номенклатуры в качестве редактора полного описания. Как сделать это модально, я разобрался, а как встроить? Как я пока понимаю, нужно создавать эту форму при вызове формы.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.