helpf.pro
Регистрация
 0 
Распечатать

Как для Подбора Элемента Справочника Открыть Форму Подбора с нужной Открытой Группой?

В продолжении Как для Выбора Элемента Справочника Открыть Форму Выбора с нужной Открытой Группой? опишу как настроить Подбор, на примере Типовой Бухгалтерии:

1. Откроем документ Реализации и зайдем в Свойства Кнопки Подбор
title

2. И так попорядку:
Кнопка вызывает процедуру:
Код 1C v 8.х
 Процедура КоманднаяПанельТоварыДействиеПодбор(Кнопка)
ДействиеПодбор(Товары);
КонецПроцедуры


Далее вызывается процедура ДействиеПодбор
Код 1C v 8.х
 Процедура ДействиеПодбор(ТабличнаяЧасть)
Перем Команда, Валюта;
ЕстьЦена = Истина;
Если ТабличнаяЧасть = Товары Тогда
Команда = "ПодборВТабличнуюЧастьТовары";
Валюта = ВалютаДокумента;
СпособЗаполненияЦен = Перечисления.СпособыЗаполненияЦен.ПоЦенамНоменклатуры;
ИмяТабличнойЧасти = "Товары";
ИначеЕсли ТабличнаяЧасть = ВозвратнаяТара Тогда
//.................Прочие условия и т.д.
КонецЕсли;

СписокВидовПодбора = СформироватьСписокЗапросовДляПодбора(ТабличнаяЧасть);
ПредставлениеДок = Метаданные().Представление();
СтруктураПараметровПодбора = Новый Структура();
СтруктураПараметровПодбора.Вставить("Команда" , Команда);
СтруктураПараметровПодбора.Вставить("СписокВидовПодбора" , СписокВидовПодбора);
// Параметры запросов.
ВременнаяДатаРасчетов = ?(НачалоДня(Дата) = НачалоДня(ТекущаяДата()), Неопределено, Дата);
СтруктураПараметровПодбора.Вставить("ДатаРасчетов" , ВременнаяДатаРасчетов);
СтруктураПараметровПодбора.Вставить("Склад" , Склад);
СтруктураПараметровПодбора.Вставить("ТипЦен" , ТипЦен);
СтруктураПараметровПодбора.Вставить("ДоговорКонтрагента", ДоговорКонтрагента);
СтруктураПараметровПодбора.Вставить("Контрагент" ,Контрагент);
СтруктураПараметровПодбора.Вставить("Организация" , Организация);
СтруктураПараметровПодбора.Вставить("СпособЗаполненияЦен" , СпособЗаполненияЦен);
СтруктураПараметровПодбора.Вставить("ЕстьЦена" , ЕстьЦена);
СтруктураПараметровПодбора.Вставить("ВалютаДокумента" , Валюта);
СтруктураПараметровПодбора.Вставить("Заголовок", "Подбор номенклатуры в документ " + ПредставлениеДок + " № " + Номер + " (" + ИмяТабличнойЧасти + ")");

РаботаСДиалогами.ОткрытьПодборНоменклатуры(ЭтаФорма, СтруктураПараметровПодбора, мФормаПодбораНоменклатуры);
КонецПроцедуры


Из нее для открытия Подбора вызывается ОткрытьПодборНоменклатуры из общего Модуля РаботаСДиалогами:
Сюда и добавляем Наши изменения
Код 1C v 8.х
 Процедура ОткрытьПодборНоменклатуры(ФормаДокумента, СтруктураПараметров, ФормаПодбора = Неопределено) Экспорт

// Добавляем обработчики в форму
МетаданныеДокумента = ФормаДокумента.ДокументОбъект.Метаданные();
Для Каждого ЭлементСтруктурыПараметров Из СтруктураПараметров Цикл
Если ОбщегоНазначения.ЕстьРеквизитДокумента(ЭлементСтруктурыПараметров.Ключ, МетаданныеДокумента) Тогда
ФормаДокумента.ПодключитьОбработчикИзмененияДанных(ЭлементСтруктурыПараметров.Ключ, "ОбновитьФормуПодбора", Ложь);
КонецЕсли;
КонецЦикла;

// Открываем форму подбора.
ФормаПодбора = Обработки.ПодборНоменклатуры.ПолучитьФорму("ОсновнаяФорма", ФормаДокумента, ФормаДокумента);
ФормаПодбора.ОбработкаОбъект.СтруктураИсходныхПараметров = СтруктураПараметров;

//- НАЧАЛО Изменения для Установки Родителя В Подборе
//НУЖНО чтобы при открытии Подбора номенклатуры Открывалась номенклатура из Групы Оргтехника (код 00000013608)
// НА ФОРМЕ ВЫБОРА СЛЕВА ЕСТЬ ДЕРЕВО ГРУПП, установим значение нужного нам Родителя в нем:
ФормаПодбора.ЭлементыФормы.ДеревоНоменклатуры.ТекущаяСтрока = Справочники.Номенклатура.НайтиПоКоду("00000013608");
// - КОНЕЦ Изменений

ФормаПодбора.Открыть();
КонецПроцедуры


Все, перезапускаем и пользуемся )
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 21681
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 20
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во время решения задачи было реш
Динамический список ~ Как программно выделить все строки динамического списка? 0
В платформе “1с предприятие 8.2 #8243; появился такой замечательный объект как “динамический список“ . Данный объект я часто использую в подборах, если не нужно делать сложные расчеты, а просто показать данные и выбрать. Бывают такие ситуации, что
Использование Web-сервисов для синхронизации баз данных в режиме online 1с 8.х 11
Часто при ведении учета в различных конфигурациях 1с возникает необходимость выполнения обмена данных. Для решения этой задачи принято использовать Универсальный обмен данными XML или другие внешние обработки, общим у которых является использование
Как для Выбора Покупателя Открыть Справочник контрагенты с открытой группой "Покупатели"? 0
// Это событие для ячейки Контрагент Табличной части Процедура КонтрагентНачалоВыбора(Элемент, СтандартнаяОбработка) Если Элемент.Значение.Пустая() Тогда СтандартнаяОбработка = Ложь; ФормаВыбора = Справочники.Контрагенты.ПолучитьФормуВыбора(
Как для Выбора Элемента Справочника Открыть Форму Выбора с нужной Открытой Группой? 7
Порядок действий такой: 1. В поле ввода " Номенклатура" добавь событие ПриНачалеВыбора. 2. Установи в них СтандартнаяОбработка = Ложь; 3. Получи форму выбора нужного справочника 4. Установи отбор по родителю 5. Открой форму для выбора Теп
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.