helpf.pro
Регистрация
 -2 
Распечатать

Функция переводит Десятичное число в Шестнадцатеричное и обратно

Код 1C v 8.х
 // Функция переводит десятичное число в шестнадцатеричное
// Параметры: _Число - Число - Десятичное число
// Возвращаемое значение: Строка - Шестнадцатеричное число
//
Функция DecToHex(Знач _Число)
База = 16;
Результат = "";
Пока _Число <> 0 Цикл
Поз =_Число % База;
Результат = Сред("0123456789ABCDEF", Поз + 1, 1) + Результат;
_Число = Цел(_Число / База);
КонецЦикла;
Возврат Результат;
КонецФункции // DecToHex()

// Функция переводит шестнадцатеричное число в десятичное
// Параметры: _Hex - Строка - Шестнадцатеричное число
// Возвращаемое значение: Число - Десятичное число
//
Функция HexToDec(Знач _Hex)
База = 16;
_Hex = СокрЛП(_Hex);
СтаршаяСтепень = СтрДлина(_Hex) - 1;
Результат = 0;
счСимволов = 1;
Пока СтаршаяСтепень >=0 Цикл
_HexСимвол = Сред(_Hex, счСимволов, 1);
Представление = Найти("0123456789ABCDEF", _HexСимвол) - 1;
Результат = Результат + Представление * Степень(База, СтаршаяСтепень);
СтаршаяСтепень = СтаршаяСтепень - 1;
СчСимволов = СчСимволов + 1;
КонецЦикла;
Возврат Результат;
КонецФункции // HexToDec()
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 8765
 -2 
Распечатать
Возможно, вас также заинтересует
Восстановление узла распределенной информационной базы из резервной копии 0
В случае возникновения ситуации, при которой необходимо восстановить резервную копию информационной базы, работающую в рамках распределенной информационной базы, можно воспользоваться следующими рекомендациями. ...
Выгрузка / Загрузка данных посредством текстовых (TXT) файлов 2
Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста . Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент загружает файл...
Выгрузка картинок из базы 1С в XML 2
В нынешнее время для электронного каталога или интернет-магазина необходимо выгружать не только информацию о цене и характеристиках товара, но и сопутствующие изображения. Хранящиеся в базе или связанные с...
Дерево значений в таблицу значений или в табличную часть и обратно 0
Для одной организации надо было реализовать документы, где вместо табличной части надо использовать дерево и все это на управляемых формах. Но дерево нельзя сохранить в базе в текущем виде. Пришлось использовать...
ЗначениеВСтрокуВнутр / ЗначениеИзСтрокиВнутр 1
Эту статью я посвящаю двум процедурам ЗначениеВСтрокуВнутр и ЗначениеИзСтрокиВнутр . Они являются полным «антиподом действий» друг другу, а разработчики 1с предприятия отнесли их в раздел «Процедуры и функции...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.